AnsweredAssumed Answered

Empty Document Detail Page

Question asked by dbrickner on Mar 20, 2009
Latest reply on Mar 20, 2009 by dbrickner
I'm running Alfresco 3 Labs on Linux. The Document Library and upload appears to work fine. I can create folders, load documents, and edit the meta on the document while in the library view. I can see thumbnails of images, txt, and pdf, but not OOo or Microsoft documents.

My real problem is when I click through to view a single document. On this page, which I'll call the detail page, everything is empty. I don't get the flash preview, in fact, the flash player never loads. I don't see any values in the Metadata section, there are no actions in the Document Actions section, and all the URL fields are empty. The comment box isn't even appearing. About the only thing that appears to be working is the document history.

The funny thing is this was, nearly, working a few hours ago. I had the flash preview trying to load (it wasn't displaying anything for office documents so I assumed it was a conversion problem) and all the other sections were populated. No it is not working.

Has anyone else had this problem? Do you have a solution or some pointers to where the problem may lie?

What has changed in that time is that I switched from Derby to MySQL. In the process, I removed (not emptied) my alf_data directory. I always have problems when doing these things, so it took me several tries before getting everything working such that I could log in again. During this process I thought the Flash uploader was broken, so following a suggestion in another forum post I downloaded new YUI code from Yahoo.

In brief, here are the changes I made, in what I think is roughly the right order:

1) Added swftools, openoffice.org-headless, Imagemagick
2) Modified custom-repository.properties to put in correct paths for pdf2swf and the Imagemagick root
3) Restarted alfresco and had flash preview mostly working at this point. The document details was working other than the preview
4) Switched to mySql by creating the database, setting permissions, modifying custom-repository.properties again. And started things up.
5) Couldn't log in. I ended up deleting alf_data, modifying the path for it to be /usr/local/Alfresco (mistakenly, not /usr/local/Alfresco/alf_data). Still couldn't log in, not even with admin/admin
6) Saw that I didn't change the setting in Hibernate dialect (forget where that is) to use MySQL, not Derby. So I changed that. Also noticed that alf_data wasn't created at last start up (because of my misconfiguration in step 5 things were scattered in the Alfresco root)
7) Restarted everything. Still couldn't log in.
8) Saw my path problem for alf_data, fixed it, alf_data related directories in my ./Alfresco root
9) Restarted everything and could now log in with admin/admin
10) Tried to upload documents but the flash loader wasn't working
11) Followed advice in other forum post to download new .js files for the YUI uploader. That didn't fix anything. Downloaded and reinstalled flash on my laptop. No joy. Tried from another computer, success. Restarted my laptop, success.
12) Now I'm at the point where I can log in, upload files with the Flash loader, see thumbnails of images and txt documents–not of office documents, and when I click through to the detail page it is mostly empty.

Any thoughts?

Outcomes