AnsweredAssumed Answered

unable to create valid FTP-rootDirectory

Question asked by hubithehawk on Jan 10, 2008
    Hello,
    I'm using Alfresco 2.1 (Tomcat bundle) with active LDAP authentication.
    In file-servers-custom.xml there is

   <config evaluator="string-compare" condition="FTP Server">
          <serverEnable enabled="true"/>
          <rootDirectory>/Alfresco/a4648</rootDirectory>
   </config>
    Now, when I connect as a Ftp-Client, I see the following:
C:\Temp>ftp ultest03.edv.dekra.de
Verbindung mit ultest03.edv.dekra.de wurde hergestellt.
220 FTP server ready
Benutzer (ultest03.edv.dekra.de:(none)): a4648
331 User name okay, need password for a4648
Kennwort:
230 User logged in, proceed
ftp> dir
200 Port OK
550 Access denied  :(
ftp> pwd
257 "/Alfresco/a4648"  :!:
    The same procedure but with line  <rootDirectory>/Alfresco/a4648</rootDirectory>
    omitted, everything works fine:
C:\Temp>ftp ultest03.edv.dekra.de
Verbindung mit ultest03.edv.dekra.de wurde hergestellt.
220 FTP server ready
Benutzer (ultest03.edv.dekra.de:(none)): a4648
331 User name okay, need password for a4648
Kennwort:
230 User logged in, proceed
ftp> cd Alfresco
250 Requested file action OK
ftp> dir
200 Port OK
150 File status okay, about to open data connection
drw-rw-rw-   1 user group 0 Nov  6 17:06 Data Dictionary
drw-rw-rw-   1 user group 0 Nov  6 17:06 Guest Home
drw-rw-rw-   1 user group 0 Nov  6 17:06 User Homes
drw-rw-rw-   1 user group 0 Nov 22 16:58 MySpace_Name
drw-rw-rw-   1 user group 0 Jan  9 09:47 a4648
-rw-rw-rw-   1 user group 39936 Dec 19 15:48 IT-DCI-noch_zu-bearbeiten.doc
226 Closing data connection
FTP: 64d Bytes empfangen in 0,09Sekunden 3,81KB/s
ftp> cd a4648
250 Requested file action OK  :)
ftp> dir
200 Port OK
150 File status okay, about to open data connection
-rw-rw-rw-   1 user group 373 Jan 10 16:42 t1.out
226 Closing data connection
FTP: 64d Bytes empfangen in 0,13Sekunden 0,39KB/s
ftp> pwd
257 "/Alfresco/a4648"  :!:  :!:
    You see, that in both case the pwd command returns the same relative path  :!: , so why in the one case it works and in the other it doesn't? (I would like to remove the necessity to change directories from my users.)

Outcomes