AnsweredAssumed Answered

Alfresco LDAP CIFS and AD Integration

Question asked by cheacox on Jan 11, 2008
Latest reply on Jan 16, 2008 by cheacox
Has anyone ran into the same error and know how to fix it:

PropertyAccessException 1: org.springframework.beans.MethodInvocationException: Property 'domain' threw exception; nested exception is org.alfresco.error.AlfrescoRuntimeException: Failed to set passthru domain, java.io.IOException: Failed to find domain controller or browse master for SMUMN …  (this seemed to be the most pertinent error; if there are other errors that I should be looking for and posting, please let me know)

This error is spured from many others in a giant peragraph, which points to the following files:
core-services-context.xml
node-services-context.xml
model-specific-services-context.xml
public-services-security-context.xml
ntlm-authentication-context.xml



I think I have configured this server to use CIFS and LDAP, pointing the appropriate files to our domain, and domain controllers as in all the documentation that we've found on the subject, and I can't seem to get past this error.

I have also tried many other ways of passing the domain name, such as smumn.edu, smumn, dc=smumn,dc=edu, etc…  in ntlm-authentication-context.xml and file-servers.xml.

Which files need to be changed from "default" in order to get Alfresco to authenticate against an Active Directory domain?

I've referenced the following and haven't found a solution:
http://wiki.alfresco.com/wiki/Configuring_NTLM
http://issues.alfresco.com/browse/AR-1555
http://wiki.alfresco.com/wiki/CIFS_linux

Does anyone have other suggestions, or pages we could look to for help with this?

Any and all help will be much appreciated!

Outcomes