AnsweredAssumed Answered

Upgrade from 3C to 3D Stable failed

Question asked by ttortosa on Mar 31, 2009
Hello,

We've been using Alfresco 3C Community during some months in CentOS 5.2, jdk 5 and tomcat 5.5, installed from installation wizard, and using the defaut derby database.

Now I'm trying to upgrade this installation to 3D version.

I've backed up my /opt/Alfresco/alf_data directory. Then I've installed 3d version in /opt/Alfresco3D… this installation has worked fine. Then I've restored my alf_data backup to the new installation. Then, when i start this 3d installation with alf_start.sh, this error is shown in tomcat log:

Mar 31, 2009 10:05:53 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Mar 31, 2009 10:05:53 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
Mar 31, 2009 10:05:53 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive share.war
Mar 31, 2009 10:06:00 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive alfresco.war
Mar 31, 2009 10:06:04 AM org.apache.catalina.core.StandardContext addApplicationListener
INFO: The listener "org.apache.myfaces.webapp.StartupServletContextListener" is already configured for this context. The duplicate definition has been ignored.
Mar 31, 2009 10:07:06 AM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Mar 31, 2009 10:07:06 AM org.apache.catalina.core.StandardContext start
SEVERE: Context [/alfresco] startup failed due to previous errors
Mar 31, 2009 10:07:08 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive studio.war
Mar 31, 2009 10:08:14 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Mar 31, 2009 10:08:14 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 140649 ms

Then I stop with alf_stop.

I do ps -ef | grep alfresco and kill all processes that runs Alfresco after alf_stop.

[root@hsle-110 Alfresco3D]# ps -ef | grep alfresco
root      2742     1  0 Mar27 ?        00:44:54 /usr/java/jdk1.5.0_17/bin/java -Xms128m -Xmx512m -XX:MaxPermSize=128m -server -XX:CompileCommand=exclude,org/apache/lucene/index/IndexReader$1,doBody -XX:CompileCommand=exclude,org/alfresco/repo/search/impl/lucene/index/IndexInfo$Merger,mergeIndexes -XX:CompileCommand=exclude,org/alfresco/repo/search/impl/lucene/index/IndexInfo$Merger,mergeDeletions -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=/opt/Alfresco3D/tomcat/conf/logging.properties -server -Xms384M -Xmx512M -XX:MaxPermSize=256M -Djava.endorsed.dirs=/opt/Alfresco3D/tomcat/endorsed -classpath :/opt/Alfresco3D/tomcat/bin/bootstrap.jar -Dcatalina.base=/opt/Alfresco3D/tomcat -Dcatalina.home=/opt/Alfresco3D/tomcat -Djava.io.tmpdir=/opt/Alfresco3D/tomcat/temp org.apache.catalina.startup.Bootstrap start
root      8410     1 13 10:05 pts/1    00:01:12 /usr/java/jdk1.5.0_17/bin/java -Xms128m -Xmx512m -XX:MaxPermSize=128m -server -XX:CompileCommand=exclude,org/apache/lucene/index/IndexReader$1,doBody -XX:CompileCommand=exclude,org/alfresco/repo/search/impl/lucene/index/IndexInfo$Merger,mergeIndexes -XX:CompileCommand=exclude,org/alfresco/repo/search/impl/lucene/index/IndexInfo$Merger,mergeDeletions -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=/opt/Alfresco3D/tomcat/conf/logging.properties -server -Xms384M -Xmx512M -XX:MaxPermSize=256M -Djava.endorsed.dirs=/opt/Alfresco3D/tomcat/endorsed -classpath :/opt/Alfresco3D/tomcat/bin/bootstrap.jar -Dcatalina.base=/opt/Alfresco3D/tomcat -Dcatalina.home=/opt/Alfresco3D/tomcat -Djava.io.tmpdir=/opt/Alfresco3D/tomcat/temp org.apache.catalina.startup.Bootstrap start

I kill this processes:  kill 2742 8410 and ps -ef returns:

[root@hsle-110 Alfresco3D]# ps -ef | grep alfresco
root      8551  8338  0 10:15 pts/1    00:00:00 grep alfresco

It's OK and then I start Alfresco alf_start.sh, and tomcat log shows just the same:

INFO: Initializing Coyote HTTP/1.1 on http-8080
Mar 31, 2009 10:16:49 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 799 ms
Mar 31, 2009 10:16:49 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Mar 31, 2009 10:16:49 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.18
Mar 31, 2009 10:16:49 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive share.war
Mar 31, 2009 10:16:54 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive alfresco.war
Mar 31, 2009 10:16:56 AM org.apache.catalina.core.StandardContext addApplicationListener
INFO: The listener "org.apache.myfaces.webapp.StartupServletContextListener" is already configured for this context. The duplicate definition has been ignored.
Mar 31, 2009 10:17:37 AM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Mar 31, 2009 10:17:37 AM org.apache.catalina.core.StandardContext start
SEVERE: Context [/alfresco] startup failed due to previous errors
Mar 31, 2009 10:17:39 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive studio.war
Mar 31, 2009 10:18:45 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Mar 31, 2009 10:18:45 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 116470 ms

I've checked that repository-properties and server.xml from tomcat configuration has the same parameters from old installation to the new.

Thanks!

Outcomes