AnsweredAssumed Answered

workflow files

Question asked by birgir on Jan 21, 2008
Latest reply on Jan 21, 2008 by davidc
Hi

I installed the alfresco-community-tomcat-2.1.0 and it went quite smoothtly. I am looking at the advanced workflow features using the graphical designer in eclipse. I made a simple workflow and deployed via eclipse and everything works fine. However I cannot find the process definition file which I just deployed. The dir tomcat\webapps\alfresco\WEB-INF\classes\alfresco\workflow shows:

23/07/2007  12:10             1,754 adhoc_processdefinition.xml
23/07/2007  12:10               876 changerequest_processdefinition.xml
23/07/2007  12:10             3,289 parallelreview_group_processdefinition.xml
23/07/2007  12:10             2,799 parallelreview_processdefinition.xml
23/07/2007  12:10             2,013 review_pooled_processdefinition.xml
23/07/2007  12:10             1,426 review_processdefinition.xml
23/07/2007  12:10             8,784 submit_processdefinition.xml
23/07/2007  12:10             4,965 wcm-workflow-messages.properties
23/07/2007  12:10             9,176 wcmWorkflowModel.xml
23/07/2007  12:10             5,172 workflow-messages.properties
23/07/2007  12:10             4,867 workflowModel.xml

I cannot see my custom process definition entitled "FirstProcess".

Also I only see two processes in the Alfresco GUI "Ad Hoc" and "Review and Approve" processes alongside my custom one. How do I get the rest ? After reading some posts I tried to lookup "workflow-context.xml.sample" I couldnt find this file either.

Outcomes