AnsweredAssumed Answered

Problem with the Sharepoint functionality

Question asked by moe on Apr 2, 2009
Latest reply on May 22, 2009 by ndemarco
Hello,

first of all, I`m pretty new to Alfresco as I`ve installed the software just yesterday.
So please don`t mind if I`m asking a beginner`s question.

I`d like to know how to get the Sharepoint support for Alfresco to work.

I`ve downloaded 'Alfresco-Labs-'3c-Mini-Setup.exe' which contains the Sharepoint functionality.
After that, the installation and configuration of Alfresco Labs went fine. I`m able to log on to Alfresco Explorer and Share.

Then, I´ve tried to use the Sharepoint functionality.
I`ve opened a Word document and set the Document Workspace to 'SPP'.
In the 'Location for new workspace' field, I set the value to 'http://10.2.181.79:7070/alfresco' and clicked on 'Create'.
Unfortunately, I received the following error message (translated from german ;-)):

'The action could not be finished. Please ask your web site administrator for further information or try again later.'

Does it really have to be port 7070?
I tried to do this with 8080, sure I had no luck, but the error message wasn`t displayed ;-)

This is a log entry directly after the server start (alf_start.bat).

16:50:46,171 INFO  [org.alfresco.config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
16:50:57,656 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.DerbyDialect.
16:50:57,656 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Alfresco is using the Apache Derby default database. Please only use this while evaluating Alfresco, it is NOT recommended for production or deployment!
16:51:00,609 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
16:51:05,453 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: C:\AlfrescoLabs3\alf_data
16:51:05,578 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
16:51:05,734 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] No patches were required.
16:51:05,750 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 2 module(s).
16:51:06,125 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Starting module 'org.alfresco.module.RecordsManagement' version 1.3.
16:51:06,546 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Starting module 'org.alfresco.module.vti' version 1.0.
16:51:08,437 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
16:51:08,562 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_07-b06; maximum heap size 506,313MB
16:51:08,562 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (c 1342) schema 1000 - Installed version 3.0.0 (c 1342) schema 1000
16:51:09,546 WARN  [org.alfresco.linkvalidation.LinkValidationServiceImpl] LinkValidationService Update is not running (virtualization server not registered or started)
16:51:24,734 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 21 Web Scripts (+0 failed), 23 URLs
16:51:24,750 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 111.88629ms)
16:51:25,296 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 134 Web Scripts (+0 failed), 136 URLs
16:51:25,328 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 574.9116ms)
16:51:25,406 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
16:51:59,312 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework

I`ve also double-clicked on 'apply_amps.bat', as I`ve  read in another post that it might be helpful to run this file.

Does anybody know what I am doing wrong?
As there are only a few threads regarding Sharepoint functionality, it doesn`t seem to be that difficult…

Thanks in advance,
moe

Outcomes