AnsweredAssumed Answered

Labs 3: FTP access not working

Question asked by toltech on Apr 6, 2009
Latest reply on Jul 8, 2009 by pescha
L.S.,
We installed a fresh alfresco labs 3. If we use any ftp client we can not access or view any directories below "/Alfresco". In "/Alfreso" we only see a couple of files, but not all files which are available. It looks like the ftp is not working correctly.

- We are not running any firewall, active /passive is not an issue
- In "/Alfresco" we can not create any subdirectories, nor upload or download files.


This a an ftp log:
ftp localhost
Connected to localhost.
220 FTP server ready
Name (localhost:root): admin
331 User name okay, need password for admin
Password:
230 User logged in, proceed
Remote system type is UNIX.
ftp> dir
200 Port OK
150 File status okay, about to open data connection
drw-rw-rw-   1 user group 0 Jan  1  1970 Alfresco
drw-rw-rw-   1 user group 0 Jan  1  1970 AVM
226 Closing data connection
ftp> cd Alfresco
250 Requested file action OK
ftp> dir
200 Port OK
150 File status okay, about to open data connection
-rw-rw-rw-   1 user group 26243442 Mar 12 12:51 20090312.zip
-rw-rw-rw-   1 user group 12541772 Mar 19 12:54 3759_20090312_1942.zip
-rw-rw-rw-   1 user group 13433523 Apr  6 14:33 test2.zip
-rw-rw-rw-   1 user group 13433523 Apr  6 14:32 XBRL_info.zip
226 Closing data connection
ftp> del test2.zip
550 Invalid path specified
ftp> get test2.zip
local: test2.zip remote: test2.zip
200 Port OK
500 Invalid path
ftp>del /Alfresco/test2.zip
550 Invalid path specified
ftp>

It looks like the ftp server is not working correctly, the webinterface is working fine however.
Does anyone have a solution or the same problem?

Our version: Version: Labs - v3.0.0 (Stable 1526)

Kind regards,
Robert

Outcomes