AnsweredAssumed Answered

CIFS not working after upgrade Labs3

Question asked by prijke on Apr 7, 2009
Hi there,

I recently upgraded our 2.1 server to Labs 3. Everything works fine, except the CIFS interface. Although, it seems to work fine accordingly to the log, I cannot connect to it via my WinXP client anymore (which was no problem beforen. And I cannot discover where to look. Any help is appreciated. I am trying to connect fron 192.168.20.124, which is appearring in the log.

Here's my log:
13:01:29,125 User:System INFO  [alfresco.smb.protocol] CIFS server started
13:01:29,125 User:System INFO  [alfresco.smb.protocol] FTP server NOT started
13:01:29,126 User:System INFO  [alfresco.smb.protocol] NFS server NOT started
13:01:29,247 User:System WARN  [alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
13:01:29,250  DEBUG [org.alfresco.fileserver] [SMB] CIFS Server MyServer starting
13:01:29,250  DEBUG [org.alfresco.fileserver] [SMB] Version 5.0.0 [beta], Java VM diablo-1.5.0_07-b01, OS FreeBSD, version 6.2-RELEASE-p8
13:01:29,250  DEBUG [org.alfresco.fileserver] [SMB] Using authenticator org.alfresco.filesys.auth.cifs.AlfrescoCifsAuthenticator, mode=USER
13:01:29,250  DEBUG [org.alfresco.fileserver] [SMB] Server timezone offset = 0hrs
13:01:29,254  DEBUG [org.alfresco.fileserver] [SMB] Dialects enabled = [Core,CorePlus,DOS LANMAN 1.0,LANMAN1.0,DOS LANMAN 2.1,LM1.2X002,LANMAN2.1,NT LM 0.12]
13:01:29,254  DEBUG [org.alfresco.fileserver] [SMB] Shares:
13:01:29,261  DEBUG [org.alfresco.fileserver] [SMB]  [Alfresco,DISK,,[Alfresco]] [Alfresco]
13:01:29,261  DEBUG [org.alfresco.fileserver] [SMB]  [AVM,DISK,,[AVM]] [AVM]
13:01:29,262  DEBUG [org.alfresco.fileserver] [SMB] Added NTServer flag to host announcement
13:01:29,275  DEBUG [org.alfresco.fileserver] [SMB] Binding TCP-SMB session handler to address : ALL
13:01:29,276  DEBUG [org.alfresco.fileserver] [SMB] Binding NetBIOS session handler to address : ALL
13:01:29,313  DEBUG [org.alfresco.fileserver] [SMB] Request handler CIFSRequestHandler_1 waiting for session …
13:01:29,316  DEBUG [org.alfresco.fileserver] [SMB] Listening for connections on [SMB,TCP-SMB,ALL:445]
13:01:29,316  DEBUG [org.alfresco.fileserver] [SMB] Listening for connections on [SMB,NetBIOS,ALL:139]
13:01:29,316  DEBUG [org.alfresco.fileserver] [SMB] Waiting for new connection …
13:01:29,318 User:System INFO  [service.descriptor.DescriptorService] Alfresco JVM - vdiablo-1.5.0-b01; maximum heap size 1012.625MB
13:01:29,318 User:System INFO  [service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (Stable 1526) schema 1002 - Installed version 2.1.0 (482) schema 64
Apr 7, 2009 1:01:46 PM org.apache.catalina.core.ApplicationContext log
INFO: ContextListener: contextInitialized()
Apr 7, 2009 1:01:46 PM org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()
Apr 7, 2009 1:01:46 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8443
Apr 7, 2009 1:01:46 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Apr 7, 2009 1:01:46 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/32  config=null
Apr 7, 2009 1:01:46 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 63752 ms
13:02:10,998  DEBUG [org.alfresco.fileserver] [SMB] Connection from /192.168.20.124:4955, handler=[SMB,NetBIOS,ALL:139], sess=N1
13:02:10,998  DEBUG [org.alfresco.fileserver] [SMB] Register session with request handler, handler=CIFSRequestHandler_1, sess=N1
13:02:10,998  DEBUG [org.alfresco.fileserver] [SMB] Waiting for new connection …
13:03:39,823  DEBUG [org.alfresco.fileserver] [SMB] Connection from /192.168.20.124:4978, handler=[SMB,NetBIOS,ALL:139], sess=N2
13:03:39,823  DEBUG [org.alfresco.fileserver] [SMB] Waiting for new connection …
13:03:39,824  DEBUG [org.alfresco.fileserver] [SMB] Register session with request handler, handler=CIFSRequestHandler_1, sess=N2
13:03:39,870  DEBUG [org.alfresco.fileserver] [N2] Negotiated SMB dialect - NT LM 0.12
13:03:39,928  DEBUG [org.alfresco.fileserver] [N2] Assigned protocol handler - org.alfresco.jlan.smb.server.NTProtocolHandler
13:04:48,027  DEBUG [org.alfresco.fileserver] [SMB] Connection from /192.168.20.124:1046, handler=[SMB,NetBIOS,ALL:139], sess=N3
13:04:48,027  DEBUG [org.alfresco.fileserver] [SMB] Waiting for new connection …
13:04:48,027  DEBUG [org.alfresco.fileserver] [SMB] Register session with request handler, handler=CIFSRequestHandler_1, sess=N3
13:05:54,718  DEBUG [org.alfresco.fileserver] [SMB] Connection from /192.168.20.124:1065, handler=[SMB,NetBIOS,ALL:139], sess=N4
13:05:54,718  DEBUG [org.alfresco.fileserver] [SMB] Waiting for new connection …
13:05:54,719  DEBUG [org.alfresco.fileserver] [SMB] Register session with request handler, handler=CIFSRequestHandler_1, sess=N4


Here's my file-servers-custom.xml
<alfresco-config area="file-servers">
<config evaluator="string-compare" condition="CIFS Server">
  <serverEnable enabled="true"/>
  <host name="MyServer" domain="MyDomain"/>
  <comment>Alfresco CIFS Server</comment>
  <!– Set to the broadcast mask for the subnet –>
  <broadcast>255.255.255.255</broadcast>
  <tcpipSMB/>
  <netBIOSSMB/>
  <hostAnnounce interval="5"/>
  <Win32NetBIOS/>
  <Win32Announce interval="5"/>
  <authenticator type="alfresco" />
  <sessionDebug flags="Negotiate,Socket"/>
</config>

Outcomes