AnsweredAssumed Answered

Tables not geting created with alfresco 2.1.0 Oracle db

Question asked by amalk on Jan 29, 2008
Latest reply on Feb 7, 2008 by amalk
Hii,
    I am trying to run alfresco 2.1 first time (not upgrading)with jboss in windows env with Oracle 9i.I have changed repository.properties and hibernate-cfg.properties accordingly.But the tables are not getting created,the table alf_bootstrap_lock has created.I droped the username and tried again but i am geting the same error below


The source of the configuration was classpath.
The diskStore path for this CacheManager will be set to C:\DOCUME~1\Amal\LOCALS~1\Temp\\ehcache_auto_created_12
To avoid this warning consider using the CacheManager factory methods to create a singleton CacheManager or spe
15:40:42,859 INFO  [Dialect] Using dialect: org.hibernate.dialect.OracleDialect
15:40:42,906 INFO  [SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.OracleDialect.
15:40:46,062 ERROR [SchemaBootstrap] Schema auto-update failed
java.sql.SQLException: ORA-00942: table or view does not exist

        at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
        at oracle.jdbc.ttc7.TTIoer.processError(TTIoer.java:289)
        at oracle.jdbc.ttc7.Oall7.receive(Oall7.java:573)
        at oracle.jdbc.ttc7.TTC7Protocol.doOall7(TTC7Protocol.java:1891)
        at oracle.jdbc.ttc7.TTC7Protocol.parseExecuteDescribe(TTC7Protocol.java:830)
        at oracle.jdbc.driver.OracleStatement.doExecuteQuery(OracleStatement.java:2391)
        at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:2672)
        at oracle.jdbc.driver.OracleStatement.executeQuery(OracleStatement.java:572)
        at org.apache.commons.dbcp.DelegatingStatement.executeQuery(DelegatingStatement.java:205)
        at org.alfresco.repo.domain.schema.SchemaBootstrap.countAppliedPatches(SchemaBootstrap.java:269)
        at org.alfresco.repo.domain.schema.SchemaBootstrap.updateSchema(SchemaBootstrap.java:427)
        at org.alfresco.repo.domain.schema.SchemaBootstrap.onBootstrap(SchemaBootstrap.java:767)
        at org.alfresco.util.AbstractLifecycleBean.onApplicationEvent(AbstractLifecycleBean.java:62)


Is there any aditional configuration that I need to do inorder to create all the tables when I am running first time…

Regards,
Amal K

Outcomes