AnsweredAssumed Answered

CIFS problem on Vista

Question asked by kbals on Jan 29, 2008
Latest reply on Apr 23, 2008 by clayroach
I'm using Alfresco Enterprise 2.1.1 on Windows Vista. I keep struggling with the CIFS access.

I tried to follow the instructions on http://forums.alfresco.com/viewtopic.php?t=938 but without effect.

This is what happens:
I start Alfesco, and it gives me the following error:

12:55:58,490 ERROR [smb.protocol.mailslot] HostAnnouncer initialization error org.alfresco.filesys.netbios.win32.WinsockNetBIOSException: 10047:CreateDatagramSocket - Address family not supported by protocol family
        at org.alfresco.filesys.netbios.win32.Win32NetBIOS.CreateDatagramSocket(
Native Method)
        at org.alfresco.filesys.netbios.win32.NetBIOSSocket.createDatagramSocket
(NetBIOSSocket.java:162)
        at org.alfresco.filesys.smb.mailslot.WinsockNetBIOSHostAnnouncer.initial
ize(WinsockNetBIOSHostAnnouncer.java:103)
        at org.alfresco.filesys.smb.mailslot.HostAnnouncer.run(HostAnnouncer.jav
a:270)

I tried to change file-servers.xml file (in the WEB-INF/classes/alfresco folder)

<Win32NetBIOS api="netbios"/>

That does avoid the exception but it does show the following errors:

14:41:04,485 ERROR [smb.protocol.mailslot] Host announce error  (LANA 2)
14:41:09,508 ERROR [smb.protocol.mailslot] Host announce error  (LANA 2)
14:41:19,523 ERROR [smb.protocol.mailslot] Host announce error  (LANA 2)
14:41:19,523 ERROR [smb.protocol.mailslot] Marked LANA as unavailable due to send errors

My PC is named pckbals, and when I do 'nbtstat -a' I get the following ouput:

Local Area Connection:
Node IpAddress: [0.0.0.0] Scope Id: []

    No names in cache

Wireless Network Connection:
Node IpAddress: [10.10.0.101] Scope Id: []

                NetBIOS Local Name Table

       Name               Type         Status
    ———————————————
    PCKBALS        <00>  UNIQUE      Registered
    ID             <00>  GROUP       Registered
    PCKBALS        <20>  UNIQUE      Registered
    ID             <1E>  GROUP       Registered
    PCKBALSA       <20>  UNIQUE      Registered
    PCKBALSA       <00>  UNIQUE      Registered

VPN Connection:
Node IpAddress: [10.0.100.3] Scope Id: []

                NetBIOS Local Name Table

       Name               Type         Status
    ———————————————
    PCKBALS        <00>  UNIQUE      Registered
    ID             <00>  GROUP       Registered
    PCKBALS        <20>  UNIQUE      Registered
    ID             <1E>  GROUP       Registered

Apparently, PCKBALSA is the Alfesco name (so NOT PCKBALS_A as explained in the readme after installation). When I try to go to \\pckbalsa I get a Windows box saying: 'Java(TM) Platform SE binary has stopped working). So the JVM crashed. I'm using the JVM that Alfresco downloaded itself (apparently it is 1.6.0_02).

I never get any errormessages about a DLL (that other people do seem to get).

Any help is welcome.

Outcomes