AnsweredAssumed Answered

Records Management fails to import Records Space

Question asked by sacco on Jan 31, 2008
Latest reply on Jul 14, 2008 by daniel.andersson
I've tried to install the Records management module on various builds of
Alfresco (most recently the last nightly build of v2.2 from the end of
October) with limited success:  the Test Data Records Space is never
imported or bootstrapped.

I've had this problem with pretty much every build I've tried since the
official 2.1 Community release, but that release is no use to me as it
cannot export data.

I've seen many posts with similar problems in these forums, and a few
claiming that this has been fixed, but (for us) the problem has always
remained.

On the JIRA: http://issues.alfresco.com/browse/RM-20
says:

The RM example ACP is no longer being bootstraped as it failed to import.

This needs to be fixed up and re-added back into the AMP.

The problem is marked as Open and Unresolved (as it has been since last
July), and it seems to correspond to our experience.

As none of the outstanding issues appears to have been resolved in the
last six months, should we assume that the RM module is dead, or at least
sleeping?

On the other hand, is it safe to assume that the rest of the bootstrapof the module  has taken place successfully, and that the module is functioning properly (and if so, what is the problem with the Test Data)?

Outcomes