AnsweredAssumed Answered

OpenOffice cannot find OpenOffice, but path correct.

Question asked by sacco on Jan 31, 2008
Latest reply on Feb 3, 2014 by gangadharjwala
I have never been able to get the new method of starting
OpenOffice to work, although I have fiddled with the
contents of  bootstrap/openoffice-startup-context.xml

No matter what I do,  the result is always something like:

03:02:22,398 User:System INFO  [domain.schema.SchemaBootstrap] No changes were made to the schema.
03:02:23,101 User:System ERROR [util.exec.RuntimeExecBootstrapBean] Bootstrap command failed:
Execution result:
   os:         Linux
   command:    "/usr/lib/openoffice.org2.0/program/soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file:///%2Fopt/alfresco/2.1-b/oouser" -nologo -headless -nofirststartwizard -nocrashrep -norestore
   succeeded:  false
   exit code:  2
   out:
   err:        "/usr/lib/openoffice.org2.0/program/soffice": not found

However, /usr/lib/openoffice.org2.0/program/soffice certainly does exists, and in fact can be started (the old way) unsing exactly this patyh by an external script and will function with Alfresco.

Any ideas why Alfreso reports that it is anuable to find this existent path?

The current contents of my (ineffective) bootstrap/openoffice-startup-context.xml
is:
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>

   <bean id="openOfficeStartupBootstrap" class="org.alfresco.util.exec.RuntimeExecBootstrapBean" >
      <property name="startupCommands">
         <list>
            <ref bean="openOfficeStartupCommand" />
         </list>
      </property>
      <property name="failOnError">
         <value>false</value>
      </property>
   </bean>

   <bean id="openOfficeStartupCommand" class="org.alfresco.util.exec.RuntimeExec">
      <property name="commandMap">
          <map>
              <entry key=".*">
                  <value><![CDATA["/usr/lib/openoffice.org2.0/program/soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file:///%2Fopt/alfresco/2.1-b/oouser" -nologo -headless -nofirststartwizard -nocrashrep -norestore]]></value>
              </entry>
          </map>
      </property>
      <property name="waitForCompletion">
         <value>false</value>
      </property>
      <property name="errorCodes">
         <value>2</value>
      </property>
   </bean>

</beans>

Outcomes