AnsweredAssumed Answered

Unable to access the custom node property in new version of

Question asked by rockycres on Apr 15, 2009
Hi,

I have added one new property called ContentId in customModel.xml file.Iam trying to get this contentid through webscripts and .ftl file.In .ftl file i used the following code to get the contentid of webfiles.

#assign search="TYPE:\"{http://www.alfresco.org/model/wcmappmodel/1.0}webfolder\"">
   <#list companyhome.childrenByLuceneSearch[search]?sort_by('name') as wp>
      <#list wp.childAssocs["wca:webuser"] as user>
         <#if user.properties["wca:username"] = person.properties.userName>
            <#assign storeId=wp.properties["wca:avmstore"]>
            <#assign username=person.properties.userName>
            <#assign sandbox=avm.userSandboxStore(storeId, username)>
            <#if avm.lookupStore(sandbox)?exists>
                  <#assign moditems = avm.getModifiedItems(storeId, username, wp.properties["wca:defaultwebapp"])>
                  <#if moditems?size != 0>
                     <#list moditems as t>
                                ${t.properties.contentId}
                           </#if>
                     </#list>
                  </#if>
            </#if>
         </#if>
      </#list>
   </#list>


This code was working fine in older version of alfresco.I have checkout the code and downloaded the Latest nightly build alfresco .After set up the port,the code was not working.when i execute the webscript, the error occured as "ContentId is undefined property".Some other property which is present in node browser is also not able to access.

Can any one help me in this.
Is there any changes i need to do to get the property

Outcomes