AnsweredAssumed Answered

smb.protocol.mailslot errors

Question asked by mmcsmith on Feb 8, 2008
Latest reply on Mar 30, 2008 by artnight
I've installed Alfresco on a PC running Windows XP Home.  I got the following error repeated endlessly in the Tomcat window when I ran alf_start.bat for the first time:

ERROR [smb.protocol.mailslot] Host announce error, 10051:SendSocketDatagram - Network is unreachable, (LANA 8 )

OK.  It's not really endless.  After 3 or 4 times, I get the following error, then the cycle repeats:

ERROR [smb.protocol.mailslot] Marked LANA as unavailable due to send errors, (LANA 8 )

I followed the directions in the README.txt file that came in the alfresco-community-tomcat-2.1.0.zip file:

1. Installed JKD 6.0.
2. Installed Alfresco.
3. Did NOT install MySQL.
4. Installed OpenOffice 2.3.1.
5. Set a JAVA_HOME variable to my JDK 6 folder.
6. Ran alf_start.bat.
7. Closed the Tomcat log window after many repetitions of the above errors.

Here's the log, through one cycle of the errors:

CompilerOracle: exclude org/apache/lucene/index/IndexReader$1.doBody
CompilerOracle: exclude org/alfresco/repo/search/impl/lucene/index/IndexInfo$Mer
ger.mergeIndexes
CompilerOracle: exclude org/alfresco/repo/search/impl/lucene/index/IndexInfo$Mer
ger.mergeDeletions
Feb 7, 2008 6:32:33 PM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Feb 7, 2008 6:32:33 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 2266 ms
Feb 7, 2008 6:32:34 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Feb 7, 2008 6:32:34 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.23
Feb 7, 2008 6:32:34 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Feb 7, 2008 6:32:35 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive alfresco.war
18:33:28,984 WARN  [remoting.rmi.RmiRegistryFactoryBean] Could not detect RMI re
gistry - creating new one
18:33:34,921 INFO  [domain.schema.SchemaBootstrap] Schema managed by database di
alect org.hibernate.dialect.HSQLDialect.
18:33:34,921 INFO  [domain.schema.SchemaBootstrap] Alfresco is using the HSQL de
fault database. Please only use this while evaluating Alfresco, it is NOT recomm
ended for production or deployment!
18:33:35,703 INFO  [domain.schema.SchemaBootstrap] Executing database script C:\
alfresco\tomcat\temp\Alfresco\AlfrescoSchemaCreate-org.hibernate.dialect.HSQLDia
lect-28618.sql (Generated).
18:33:35,906 INFO  [domain.schema.SchemaBootstrap] Executing database script C:\
alfresco\tomcat\temp\Alfresco\AlfrescoSchemaUpdate-org.hibernate.dialect.HSQLDia
lect-28619.sql (Copied from classpath:alfresco/dbscripts/create/2.1/org.hibernat
e.dialect.HSQLDialect/AlfrescoPostCreate-2.1-FKIndexes.sql).
18:33:35,953 INFO  [domain.schema.SchemaBootstrap] All executed statements writt
en to file C:\alfresco\tomcat\temp\Alfresco\AlfrescoSchemaUpdate-All_Statements-
28620.sql.
18:35:05,093 WARN  [repo.admin.ConfigurationChecker] The Alfresco 'dir.root' pro
perty is set to a relative path './alf_data'.  'dir.root' should be overridden t
o point to a specific folder.
18:35:05,093 INFO  [repo.admin.ConfigurationChecker] The Alfresco root data dire
ctory ('dir.root') is: .\alf_data
18:35:05,125 INFO  [admin.patch.PatchExecuter] Checking for patches to apply …

18:35:05,187 INFO  [repo.module.ModuleServiceImpl] Found 0 module(s).
18:35:05,593 INFO  [service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_
04-b12; maximum heap size 506.313MB
18:35:05,593 INFO  [service.descriptor.DescriptorService] Alfresco started (Comm
unity Network): Current version 2.1.0 (482) schema 64 - Installed version 2.1.0
(482) schema 64
Feb 7, 2008 6:35:08 PM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Feb 7, 2008 6:35:08 PM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Feb 7, 2008 6:35:08 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 154969 ms
18:35:12,359 ERROR [smb.protocol.mailslot] Host announce error, 10051:SendSocket
Datagram - Network is unreachable, (LANA 8)
18:35:17,359 ERROR [smb.protocol.mailslot] Host announce error, 10051:SendSocket
Datagram - Network is unreachable, (LANA 8)
18:35:27,359 ERROR [smb.protocol.mailslot] Host announce error, 10051:SendSocket
Datagram - Network is unreachable, (LANA 8)
18:35:27,359 ERROR [smb.protocol.mailslot] Marked LANA as unavailable due to sen
d errors, (LANA 8)

Any idea what might be wrong?  I didn't get much help searching the forums, so I would appreciate any ideas the members might have.  (Tip: I'm mainly a boxed application person, but I can follow instructions reasonably well.)

Mark

Outcomes