AnsweredAssumed Answered

Custom cmis properties defined through aspects gone in 3.2?

Question asked by syberyan on May 12, 2009
Latest reply on May 20, 2009 by jfullam
Hi,

I've been working on a cmis project where I defined a custom datamodel in alfresco, where some of the properties are defined through aspects.
The build I had been using until now was version 3.0.0 (e dev 1688) (nightly build).

This worked fine: I could set and get all custom properties through the cmis rest API.
A few days ago I upgraded my install to version 3.2.0 (_Preview2_dev 1837), to check the latest cmis additions.
To my suprise it appeared that all my custom properties that are defined through aspects don't show up anymore through cmis, and aren't settable anymore either. I get:

"Property "custommodel_customproperty" is not a known property for type D/custommodel_custom_type"

Properties that are defined directly on the custom type still work though.

Is this supposed to have changed? I need to work through aspects, because some custom types that don't share the same parent need to have the same properties.

I also tried 3.2 preview 1, but that was even worse as I couldn't set any custom property.

Any help appreciated!
Chris

Outcomes