AnsweredAssumed Answered

Permission Group

Question asked by chicco0386 on May 12, 2009
Latest reply on May 20, 2009 by safir
Hi,

I'm using Alfresco 3.1 Labs….

I want to create a new permissionGroup of Users….

So I've operate  like this:

1) open the XML file tomcat/webapps/alfresco/WEB-INF/classes/alfresco/model/permissionDefinitions.xml
2) write this
<permissionGroup name="SolaScrittura" allowFullControl="false" expose="true" >

          <includePermissionGroup permissionGroup="WriteContent" type="sys:base" />

      </permissionGroup>
under the
<!– ================================================ –>

   <!– Permissions available to all content and folders –>

   <!– ================================================ –>

3) after under
<!– =============================== –>

   <!– Permissions specific to content –>

   <!– =============================== –>

I alowed the Group

<permissionSet type="cm:content" expose="selected">



      <!– Content specific roles.                                                       –>

     

      <permissionGroup name="Coordinator" extends="true" expose="true"/>

      <permissionGroup name="Collaborator" extends="true" expose="true"/>

      <permissionGroup name="Contributor" extends="true" expose="true"/>

      <permissionGroup name="Editor" extends="true" expose="true"/>

      <permissionGroup name="Consumer" extends="true" expose="true"/>

      <permissionGroup name="RecordAdministrator" extends="true" expose="false"/>
      <permissionGroup name="SolaScrittura" extends="true" expose="true"/>

     

   </permissionSet>

   

   

    <permissionSet type="cm:folder" expose="selected">



      <!– Content folder specific roles.                                                       –>

     

      <permissionGroup name="Coordinator" extends="true" expose="true"/>

      <permissionGroup name="Collaborator" extends="true" expose="true"/>

      <permissionGroup name="Contributor" extends="true" expose="true"/>

      <permissionGroup name="Editor" extends="true" expose="true"/>

      <permissionGroup name="Consumer" extends="true" expose="true"/>

      <permissionGroup name="RecordAdministrator" extends="true" expose="false"/>
      <permissionGroup name="SolaScrittura" extends="true" expose="true"/>

     

   </permissionSet>

4) I've restart the server
5) but when I go into the specified window for apply permission I've this:
[img]http://img254.imageshack.us/img254/3551/immaginesdu.png[/img]

I set the "SolaScrittura", but it appear like into the immage…. $$SolaScrittura$$

Why?
And after, when I try the set permission, it don't work because the error is that I don't have the permission to write….

HELP ME PLEASE
I'VE DO SOME ERRORS?

PLEASE

Outcomes