AnsweredAssumed Answered

problems with openoffice and imagemagick on jboss on a mac

Question asked by inspiron82 on May 13, 2009
Latest reply on May 14, 2009 by mahkath
hi,
in my custom-repository.properties i have:

dir.root=/Users/Inspiron/Alfresco/alf_data
dir.indexes=/Users/Inspiron/Alfresco/alf_data/lucene-indexes

ooo.exe=/Users/Inspiron/Alfresco/OpenOffice.app/Contents/program/soffice
ooo.user=${dir.root}/ooouser
img.root=/Users/Inspiron/Alfresco/ImageMagick-6.4.6


When i start jboss, i have the following errors:


00:35:27,057 INFO  [STDOUT] 00:35:27,056  ERROR [transform.magick.AbstractImageMagickContentTransformer] ImageMagickContentTransformer not available: Failed to perform ImageMagick transformation:
Execution result:
   os:         Mac OS X
   command:    convert /tmp/Alfresco/ImageMagickContentTransformer_init_source_48209.gif  /tmp/Alfresco/ImageMagickContentTransformer_init_target_48210.png
   succeeded:  true
   exit code:  133
   out:       
   err:        dyld: Library not loaded: /ImageMagick-6.4.6/lib/libMagickCore.1.dylib
  Referenced from: /Users/Inspiron/Alfresco/ImageMagick/bin/convert
  Reason: image not found


00:35:44,913 INFO  [STDOUT] 00:35:44,913  ERROR [util.exec.RuntimeExecBootstrapBean] Bootstrap command failed:
Execution result:
   os:         Mac OS X
   command:    "/Users/Inspiron/Alfresco/OpenOffice.app/Contents/program/soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" "-env:UserInstallation=file://oouser" -nologo -headless -nofirststartwizard -nocrashrep -norestore
   succeeded:  false
   exit code:  2
   out:       
   err:        "/Users/Inspiron/Alfresco/OpenOffice.app/Contents/program/soffice": not found

do you know why?
thanks

Outcomes