AnsweredAssumed Answered

creating webscripts

Question asked by mattek on Jun 3, 2009
Latest reply on Jun 24, 2009 by mrogers
Hello,

I am using Alfresco 3.0 build 1526. I tried to install RAAr AMP module but after modifing and deploy the WAR the RAAr Web Script where not recognized even viewing that . Accessing the Web Script URL gave me HTTP 404 error. So investigating the Web Script architecture to find the problem I tried to change URL of an existent Web Script to see if Alfresco get the changes. I was surprised that, after changing the URL for the class/alfresco/templates/webscripts/org/alfresco/repository/login.get.desc.xml from "/api/login?u={username}&pw={password?}" to "/pippo/login?u={username}&pw={password?}" and removing content of work and temp directory of tomcat, the change didn't affect the Alfresco behaviour. Old URL was still accessible and new URL gave me an HTTP 404 error.

Why RAAr Web Scripts are not recognized from Alfresco? Why a change in existing Web Scripts configuration does not produce the espected change? What I did wrong?  :?

Surely I forgot something I hope you guys could give me some more hints to investigate the problem.

regards,
Matteo

Outcomes