AnsweredAssumed Answered

Configure Alfresco to use a proxy server

Question asked by rbowman on Jun 8, 2009
Latest reply on Dec 17, 2010 by nhienmai
Hello!

Is there any way to configure Alfresco to use a proxy server?  Here's the problem I am facing.

When using Web Studio, when I go to create a new website, I get the following error:

14:00:22,567  DEBUG [web.scripts.AbstractRuntime] Caught exception: org.alfresco.web.scripts.WebScriptException: Failed to load script '/web-studio/api/prebuilt/list.get.js (in classpath store file:/home/rbowman/Applications/Alfresco/tomcat/webapps/studio/WEB-INF/classes/alfresco/webscripts)': TypeError: Cannot read property "results" from null (file:/home/rbowman/Applications/Alfresco/tomcat/webapps/studio/WEB-INF/classes/alfresco/webscripts/web-studio/api/prebuilt/list.get.js#47)

I have read in http://forums.alfresco.com/en/viewtopic.php?f=36&t=16543&start=0&st=0&sk=t&sd=a that Web Studio is attempting to connect to https://network.alfresco.com/extranet in order to get a list of templates.

The problem is that in order for Web Studio to make this connection, it must go through a proxy server.  This is set in stone and directly connecting to https://network.alfresco.com/extranet is not an option.

I have tried adding -Dhttp(s).proxyHost and -Dhttp(s).proxyPort options to alfresco.sh, but that did not work.  I have also tried adding http(s).proxyHost/Port to custom-repository.properties.  Using wireshark, I have verified that Web Studio is attempting to make a direct connection to network.alfresco.com.  I have searched the forums/wiki over and cannot seem to find anything on this issue.

Can anyone help?  I am stuck….

Thanks in advance,
-Roger Bowman

Outcomes