AnsweredAssumed Answered

Alfresco Authentication in Web Scripts

Question asked by anup_nair01 on Jun 9, 2009
Latest reply on Mar 31, 2011 by flopez
Hi,

We are facing problems with web script authentication. We are unable to understand what differences /service, /wcservice and /168service cause.
We are interfacing Liferay with Alfresco 3.0.0 Stable(LDAP configured) using AWPr portlets. The basic webscript we are trying to configure is an upload webscript. We are not using the all-in-one MySpaces Web script and implementing Upload and Browse separately. We found the Upload script on the Web Script Examples Wiki entry. But sending alf_ticket is not automatically authenticating the user. The Authentication level for the scripts is set at "user".
The script worked once and the uploaded file was stored in the ticket holding user's folder. The script never worked like that again. Sorry if it's sounding like a ghost story. But this is exactly what happened. No changed were made yet, the script then stopped functioning like it was supposed to.

Pls help, thanks
Anup

Outcomes