AnsweredAssumed Answered

Problems configuring CIFS: Null CIFS logon allowed

Question asked by johang on Jun 12, 2009
Hi,

I've struggled with this problem for a couple of days now and I can't see to get this to work.

I've installed alfresco-labs-tomcat-3Stable.zip (I couldn't seem to get Alfresco-Labs-3Stable-Linux-x86-Install to work) on Ubuntu 8.04LTS. I think this is Labs 3d. I've installed the module alfresco-crowd-security and configured Alfresco to use Crowd for authentication. I got this part working nicely and I can login to /alfresco and /alfresco/webdav.

I'm however experiencing problems configuring CIFS. I get the following message in alfresco.log:
[snip]
11:19:21,210 DEBUG [org.alfresco.smb.protocol.auth] Null CIFS logon allowed
11:19:21,222 DEBUG [org.alfresco.smb.protocol.auth]   No PassthruDetails for T8
11:19:22,241 DEBUG [org.alfresco.smb.protocol.auth]   No PassthruDetails for T8
11:19:22,247 DEBUG [org.alfresco.smb.protocol.auth]   No PassthruDetails for T9
11:19:22,252 DEBUG [org.alfresco.smb.protocol.auth]   No PassthruDetails for T10
11:19:23,199 DEBUG [org.alfresco.smb.protocol.auth] Null CIFS logon allowed
11:19:23,202 DEBUG [org.alfresco.smb.protocol.auth]   No PassthruDetails for T10
11:19:23,460 DEBUG [org.alfresco.smb.protocol.auth]   No PassthruDetails for T11
11:19:43,219 DEBUG [org.alfresco.smb.protocol.auth]   No PassthruDetails for T12
11:19:44,223 DEBUG [org.alfresco.smb.protocol.auth] Null CIFS logon allowed
11:19:44,227 DEBUG [org.alfresco.smb.protocol.auth]   No PassthruDetails for T12
[/snip]

I've googled this issue and found some similar issues but this one is almost the same: https://issues.alfresco.com/jira/browse/ETHREEOH-531. I've tried the solution but it didn't work.

My file-servers.xml looks like this:

<alfresco-config area="file-servers">

        <config evaluator="string-compare" condition="CIFS Server" replace="true">
                <serverEnable enabled="true"/>
                <host name="${cifs.localname}A" domain="${cifs.domain}"/>
                <comment>Alfresco CIFS Server</comment>
               <broadcast>${cifs.broadcast}</broadcast>
                <tcpipSMB platforms="linux,solaris,macosx"/>
                <netBIOSSMB platforms="linux,solaris,macosx"/>
                <!– CIFS authentication –>
                <authenticator type="passthru">
                        <Server>11.22.33.44</Server>
                </authenticator>
                <sessionDebug flags="Negotiate,Notify,Socket,Tree,Errors,State"/>
        </config>

        <config evaluator="string-compare" condition="Filesystems">
                <filesystems>

                        <filesystem name="Alfresco">
                        <store>workspace://SpacesStore</store>
                        <rootPath>/app:company_home</rootPath>

                        <!– Add a URL file to each folder that links back to the web client –>
                        <urlFile>
                                <filename>__Alfresco.url</filename>
                                <webpath>http://${localname}:8080/alfresco/</webpath>
                        </urlFile>

                        <!– Mark locked files as offline –>
                        <offlineFiles/>
                        <desktopActions>
                                <global>
                                        <path>alfresco/desktop/Alfresco.exe</path>
                                        <webpath>http://${localname}:8080/alfresco/</webpath>
                                </global>
                                <action>
                                        <class>org.alfresco.filesys.repo.desk.CheckInOutDesktopAction</class>
                                        <name>CheckInOut</name>
                                        <filename>__CheckInOut.exe</filename>
                                </action>
                                <action>
                                        <class>org.alfresco.filesys.repo.desk.JavaScriptDesktopAction</class>
                                        <name>JavaScriptURL</name>
                                        <filename>__ShowDetails.exe</filename>
                                        <script>alfresco/desktop/showDetails.js</script>
                                        <attributes>anyFiles</attributes>
                                        <preprocess>copyToTarget</preprocess>
                                </action>
                        </desktopActions>
         </filesystem>

         <avmfilesystem name="AVM">
            <virtualView stores="site,staging,author" />
         </avmfilesystem>

      </filesystems>
   </config>

        <config evaluator="string-compare" condition="Filesystem Security">
                <authenticator type="passthru">
                        <Server>11.22.33.44</Server>
                </authenticator>
        </config>
</alfresco-config>
11.22.33.44 is the Crowd Server

I don't think this issue is related to the alfresco-crowd-security module but rather a configuration issue. When I run 'smbclient -U admin \\localhost\alfresco' from the alfresco-server I get: session setup failed: NT_STATUS_LOGON_FAILURE and I see Null CIFS logon allowed etc in the log-file.

I've tried several possible configuration-options but still no solution. I'm getting pretty desperate and running out of ideas so any hints are appreciated.

Cheers,

Johan

Outcomes