AnsweredAssumed Answered

VTI cannot authenticate through File > Open

Question asked by tgmweb on Jul 1, 2009
Latest reply on Sep 17, 2009 by jpv
Got a weird issue here - where I can save a Word Document to a Alfresco Space, but I can't open any. I have to open the file locally (at which point it informs me it's also on the alfresco share and prompts me to update it).

When I try to open from Word (File > Open http://192.168.1.123:7070/alfresco), it prompts me for a password but then doesn't accept it (and the prompt re-appears).

Username and password are definately correct, as I can save to the workspace using the same credentials and login on port 8080.


16:52:48,246 User:admin DEBUG [vti.web.VtiFilter] Checking request for VTI or not
16:52:48,246 User:admin DEBUG [vti.web.VtiFilter] Return VTI answer for HEAD request
16:52:48,246 User:admin DEBUG [vti.web.VtiFilter] Checking is resource exist
16:52:48,246 User:admin DEBUG [vti.web.VtiFilter] Authenticate the user 'admin'
16:52:48,248 User:admin DEBUG [alfresco.v3.AlfrescoMethodHandler] WebUrl: /alfresco, fileUrl: ''
16:52:49,963 User:admin DEBUG [vti.web.VtiFilter] Checking request for VTI or not
16:52:49,963 User:admin DEBUG [vti.web.VtiFilter] Return VTI answer for HEAD request
16:52:49,963 User:admin DEBUG [vti.web.VtiFilter] Checking is resource exist
16:52:49,963 User:admin DEBUG [vti.web.VtiFilter] Authenticate the user 'admin'
16:52:49,965 User:admin DEBUG [alfresco.v3.AlfrescoMethodHandler] WebUrl: /alfresco, fileUrl: ''

That's my log file - it just doesn't want to authenticate.

Also - if I go to http://192.168.1.123:7070 in firefox or IE - I get the same never-ending login prompt.

I'm just using out-of-the-box standard authentication using the default admin account alfresco comes setup with.

Oh, running on tomcat, CentOS, and MySQL.

Anyone any ideas?


Tom.

Outcomes