AnsweredAssumed Answered

Problem with Alfresco OpenOffice.org plugin

Question asked by zenobiusz on Jul 6, 2009
Latest reply on Jul 6, 2009 by thestorm
Hi everyone!

I'm trying to use the Alfresco OpenOffice.org plugin but I have same problem.

I've got Microsoft Windows Server 2003 with Alfresco Enterprise Edition 3.0 and Ubuntu 8.10 with OpenOffice 2.4.1 as the client application.

I've downloaded dist-linux-jdk15-en.zip from http://forge.alfresco.com/frs/?group_id=157 and I did everything like it was in install.txt file.
After all in OpenOffice I have Alfresco toolbar witch is visible and colored but when I click on this toolbar nothing happen (it doesn't open any Alfresco view).

Additionally, when I trying start Alfresco on Windows Server 2003 I get the following error message:


16:01:24,031  ERROR [util.exec.RuntimeExecBootstrapBean] Bootstrap command faile
d:
Execution result:
   os:         Windows 2003
   command:    [C:/Alfresco3/openoffice/OpenOffice.org 3/program/soffice, "-acce
pt=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager", "-env:UserIns
tallation=file:///C:/Alfresco3/alf_data/oouser", -nologo, -headless, -nofirststa
rtwizard, -nocrashrep, -norestore]
   succeeded:  false
   exit code:  2
   out:
   err:        CreateProcess: "C:\Alfresco3\openoffice\OpenOffice.org 3\program\
soffice" "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager"
"-env:UserInstallation=file:///C:/Alfresco3/alf_data/oouser" -nologo -headless
-nofirststartwizard -nocr
16:01:26,453 User:System INFO  [repo.admin.ConfigurationChecker] The Alfresco ro
ot data directory ('dir.root') is: C:\Alfresco3\alf_data
16:01:26,593 User:System INFO  [admin.patch.PatchExecuter] Checking for patches
to apply …
[/code]

I'm not the expert from Linux. I tried configure /ooo2alf.jar/config/setting.properties file in /home/…/.openoffice.org2/user/uno_packages/cache/uno_packages/MLGjgP_/ooo2alf-linux.oxt. I set there default.web.client.base.url and default.webav.client.base.url to my IP address to Windows Server 2003 where I have Alfresco. But I don't know it's good idea and in fact, it still doesn't work.

Maybe anybody has any suggestion where I did mistake or maybe I forgot about something.

Thanks for any help.

Best regards
            zeno

Outcomes