AnsweredAssumed Answered

Web Studio doesn't work?

Question asked by whybish on Jul 7, 2009
Latest reply on Jul 9, 2009 by uzi
We are trying to follow the studio tutorials.  Currently we are trying them with 3.2 final, but we have also tried with the Nightly, 3.1 final, 3.0 final.
http://wiki.alfresco.com/wiki/Web_Studio_Tutorials
When we click on create new website the "based on the following" field does not load (in either I.E. or FF)

When we try the second tutorial from a site built from scratch we get a massive stack trace when we drag and drop a web form from the data dictionary onto a page region.  When we try to edit the region the edit/delete icons are not there.

When we drop an html component onto the region and configure it the region gets completely removed from the template.  We now have a home page with no regions in it at all.

When we use an include component we don't know what to use for the endpoint and value fields, everything we have tried results in a stack trace being displayed.

When we use 3.2 final we only see three edit icons for the site, rather than the four in hte nightly build.

When we download the nightly build it shows it was built on ~18 June which is about 3 weeks ago.

When we make any change to a site in the nightly build (e.g. add and configure a component) the component editor does not disappear, it just blanks out and stays there.  When we refresh the page the page still hangs, so after each edit we need to shut and reopen the browser to view the results of the changes.  Some times refresh does 'work' but it sets the editing mode to preview and removes the sidebar, so that you need to change the mode and add the sidebar back in to continue.

When we create a web form and add content, the submit button is not checked by default.

When we create a content for a web form the content does not appear in the browse view (sometimes the xml appears for the content sometimes not, but the html never appears, although it sometimes appears in the modified items).

When we have created content for a web form we cannot see that content in studio.

When the studio icons are expanded so that all four (or three) are shown then mousing over them makes you realise that each is clickable.  This does not happen for the initial state where they are not all visible.  This made us think that studio was busted when we grabbed the version that started using these icons because the first thing you need to realise is that you must click on the icon that has no mouseover/alt etc that lets you know it is clickable.

When you log into studio the enter button does not cause the login to be submitted.

In some places in studio you have to click on the (very tiny) icon for a link to be followed but you can't click on the text.  For some of the context menus you have to click on the text, clicking on the icon causes the menu to disappear.

We can bulk import the sample.war file, but if we change a file in the sample.war file and redo the bulk import we get an error stating that the child exists.  To get the updates in we either need to create a complete new web project and redo all our work, or delete all the stuff that was imported previously.  It takes ~5 clicks to delete each thing and there are ~20 things to delete.  There is no option to overwrite.

When we try to submit the deletion we get:
javax.faces.FacesException: Error calling action method of component with id dialog:finish-button
caused by:
javax.faces.el.EvaluationException: Exception while invoking expression #{DialogManager.finish}
caused by:
org.alfresco.service.cmr.avmsync.AVMSyncException: 06080030 Conflict prevents update.

The sample site includes a footer webform and a press release webform.  If you create a press release content before a footer content then you get a textbox field for the footer, and whatever you put in will cause the creation to crap out during the next step of the wizard.  If you create the footer first then you get a radio button as expected.  Why allow the user to enter free text when nothing will ever work?

Is studio supposed to be usable?

Outcomes