AnsweredAssumed Answered

Error logging in to /share on port 80

Question asked by blouro on Jul 8, 2009
Latest reply on Jul 8, 2009 by dward
I changed the tomcat server.xml file to run on port 80. When I run localhost/share the login page comes up however when I try to log in as any user even admin with password admin it won't allow me to. It says "The remote server may be unavailable or your authentication details have not been recognized."

If i try to log into localhost/alfresco it works just fine. I can log in and view the sites and members.

I am not running behind apache and my log file produces no errors. I don't have any other services running on port 80 either. Does anyone have any idea?

This is a copy of my log file.




13:22:45,833 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
13:23:05,085 ERROR [org.alfresco.repo.content.transform.magick.AbstractImageMagickContentTransformer] ImageMagickContentTransformer not available: Failed to perform ImageMagick transformation:
Execution result:
   os:         Linux
   command:    [/usr/local/bin/convert, /opt/Alfresco/tomcat/temp/Alfresco/ImageMagickContentTransformer_init_source_1800788963572159024.gif, /opt/Alfresco/tomcat/temp/Alfresco/ImageMagickContentTransformer_init_target_1556287582542908866.png]
   succeeded:  false
   exit code:  1
   out:       
   err:        Cannot run program "/usr/local/bin/convert": java.io.IOException: error=2, No such file or directory
13:23:06,973 INFO  [org.alfresco.config.xml.XMLConfigService$PropertyConfigurer] Loading properties file from class path resource [alfresco/file-servers.properties]
13:23:12,270 ERROR [org.alfresco.repo.content.transform.RuntimeExecutableContentTransformer] Failed to start a runtime executable content transformer:
Execution result:
   os:         Linux
   command:    [/opt/Alfresco/bin/pdf2swf, -V]
   succeeded:  false
   exit code:  1
   out:       
   err:        Cannot run program "/opt/Alfresco/bin/pdf2swf": java.io.IOException: error=2, No such file or directory
13:23:20,446 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
13:23:21,769 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
13:23:24,458 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /opt/Alfresco/alf_data
13:23:24,506 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
13:23:24,756 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] No patches were required.
13:23:24,760 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 0 module(s).
13:23:29,949 ERROR [org.alfresco.smb.protocol] Failed to get local domain/workgroup name, using default of WORKGROUP
13:23:29,949 ERROR [org.alfresco.smb.protocol] (This may be due to firewall settings or incorrect <broadcast> setting)
13:23:30,510 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_13-b03; maximum heap size 506.313MB
13:23:30,512 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Labs): Current version 3.0.0 (Stable 1526) schema 1002 - Installed version 3.0.0 (Stable 1526) schema 1002
13:23:50,223 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 67 Web Scripts (+0 failed), 71 URLs
13:23:50,225 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 392.95694ms)
13:23:50,721 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 101 Web Scripts (+0 failed), 105 URLs
13:23:50,721 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 479.88718ms)
13:23:50,785 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework


Thanks for your help,
blouro

Outcomes