AnsweredAssumed Answered

IMAP bound to localhost, how do I change it?

Question asked by warmbowski on Jul 9, 2009
Latest reply on May 19, 2010 by elibra
After install of Alfresco CE 3.2 on CentOS 5.1, I enabled IMAP in the alfresco-global.properties file using these settings:

imap.server.enabled=true
imap.server.port=143
imap.server.host=alfresco.mydomain.com

IMAP is up and running but the protocol seems to bound to localhost only, as displayed by 'netstat -ln':

tcp        0      0 ::ffff:127.0.0.1:143        :::*                        LISTEN

so I cannot connect to it from an email client on another computer. When I telnet into port 143 from the localhost, I get:

* OK IMAP4rev1 Server GreenMail ready

When I telnet in from another computer, I get:

Connecting To alfresco.mydomain.com…Could not open connection to the host, on port 143: Connect failed

How do I change this setting and bind IMAP protocol to my Alfresco server's ip address?

Outcomes