AnsweredAssumed Answered

Wrong locale with the Java Web service

Question asked by elvo on Oct 12, 2011
Latest reply on Oct 13, 2011 by loftux
Hi everyone,

I'm having some issues with my Alfresco Community 3.4d and I'd like to know if I have done something wrong, or forgotten to do something important.

I've installed Alfresco and Share on a server and configured them to suit my needs. No issue here: new aspect, custom properties… Then, I've created some files (with Share) with a title and a description (cm:titled aspect + some of my custom aspects as well). Still no issue. On another computer, I'm using the Alfresco Java Web service client to access those data. Still works like a charm. But then, that's where things get complicated.

I've created some user accounts for my coworkers to create and modify those files (title, description and content among other things). Everything went smoothly in Share. However, whenever I try to access those modification using the Alfresco Web service, I can't see them on title and description. I can however see them on my customized properties (mostly cm:text fields). I was wondering if I had done something wrong in the call but I have bump into something, I believe, is related. When I connect to Alfresco Explorer with my admin account, I can't see the modifications my coworkers have done. However, if I change the Content filter language in my user profile to French (All our Share user account are in French), I can see them.

So I was wondering: is there anyway to disable that feature (although I've already disable the multilingual feature) on mltext fields? Is there anyway to indicate what locale I want the web service to use?

Thanks in advance,

Outcomes