AnsweredAssumed Answered

Explorer stops working

Question asked by mattparker on Jul 28, 2009
Latest reply on May 17, 2010 by pondermuse
I was going to make a change to one of the config files in Alfresco. I stopped the server and backed up my installation. Next I made the change to the config file and immediately received a 404 error after restarting the server and attempting to reconnect. So, I stopped the server again, un-did my changes and started the server again. Now Explorer will not start up correctly. Here is the output of the alfresco.log file.
08:03:10,442 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from class path resource [alfresco/repository.properties]
08:03:10,446 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from class path resource [alfresco/domain/transaction.properties]
08:03:10,446 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from URL [file:/Volumes/Admin/Alfresco/tomcat/shared/classes/alfresco-global.properties]
08:03:10,651 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
08:03:48,234 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
08:03:50,300 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
08:03:55,605 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'thirdparty' subsystem, ID: [default]
08:03:55,656 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
08:03:57,268 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
08:03:57,270 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'thirdparty' subsystem, ID: [default] complete
08:03:57,527 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /Volumes/Admin/Alfresco/alf_data
08:03:57,627 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
08:03:58,382 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] No patches were required.
08:03:58,412 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 1 module(s).
08:03:58,540 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Starting module 'org.alfresco.module.vti' version 1.2.
08:03:58,801 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'fileServers' subsystem, ID: [default]
08:03:58,845 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
08:04:00,904 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'Authentication' subsystem, ID: [managed, alfrescoNtlm1]
08:04:00,951 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
08:04:01,536 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'Authentication' subsystem, ID: [managed, alfrescoNtlm1] complete
08:04:01,584 ERROR [org.alfresco.fileserver] Failed to get local domain/workgroup name, using default of WORKGROUP
08:04:01,584 ERROR [org.alfresco.fileserver] (This may be due to firewall settings or incorrect <broadcast> setting)
08:04:01,683 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'fileServers' subsystem, ID: [default] complete
08:04:01,684 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'imap' subsystem, ID: [default]
08:04:01,716 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
08:04:01,843 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'imap' subsystem, ID: [default] complete
08:04:01,844 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'Synchronization' subsystem, ID: [default]
08:04:01,923 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
08:04:01,957 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'Synchronization' subsystem, ID: [default] complete
08:04:02,027 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.5.0_19-b02-304; maximum heap size 506.313MB
08:04:02,028 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Community): Current version 3.2.0 (2039) schema 2019 - Installed version 3.2.0 (2039) schema 2019
08:04:02,587 INFO  [org.alfresco.module.vti.VtiServer] Vti server started successfully on port: 7070
08:04:02,641 ERROR [org.springframework.web.context.ContextLoader] Context initialization failed
java.lang.RuntimeException: No root found for :
   root path: /app:company_home/st:sites
   at org.alfresco.module.vti.handler.alfresco.VtiPathHelper$2.doWork(VtiPathHelper.java:502)
   at org.alfresco.module.vti.handler.alfresco.VtiPathHelper$2.doWork(VtiPathHelper.java:484)
   at org.alfresco.repo.security.authentication.AuthenticationUtil.runAs(AuthenticationUtil.java:489)
   at org.alfresco.module.vti.handler.alfresco.VtiPathHelper.onBootstrap(VtiPathHelper.java:482)
   at org.alfresco.util.AbstractLifecycleBean.onApplicationEvent(AbstractLifecycleBean.java:62)
   at org.springframework.context.event.SimpleApplicationEventMulticaster$1.run(SimpleApplicationEventMulticaster.java:77)
   at org.springframework.core.task.SyncTaskExecutor.execute(SyncTaskExecutor.java:49)
   at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:75)
   at org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:246)
   at org.springframework.context.support.AbstractApplicationContext.finishRefresh(AbstractApplicationContext.java:617)
   at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:355)
   at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:246)
   at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:189)
   at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:49)
   at org.alfresco.web.app.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:69)
   at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3843)
   at org.apache.catalina.core.StandardContext.start(StandardContext.java:4342)
   at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
   at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
   at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
   at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:627)
   at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
   at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
   at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1149)
   at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
   at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
   at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
   at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
   at org.apache.catalina.core.StandardService.start(StandardService.java:516)
   at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
   at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:585)
   at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
   at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
08:04:07,935 INFO  [org.alfresco.config.JBossEnabledWebApplicationContext] Refreshing org.alfresco.config.JBossEnabledWebApplicationContext@6bf20b: display name [Root WebApplicationContext]; startup date [Tue Jul 28 08:04:07 EDT 2009]; root of context hierarchy
08:04:09,694 INFO  [org.alfresco.config.JBossEnabledWebApplicationContext] Bean factory for application context [org.alfresco.config.JBossEnabledWebApplicationContext@6bf20b]: org.springframework.beans.factory.support.DefaultListableBeanFactory@f9bb9d
08:04:11,898 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 24 Web Scripts (+0 failed), 26 URLs
08:04:11,947 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised Presentation Web Script Container (in 473.645ms)
08:04:12,226 INFO  [org.alfresco.web.scripts.DeclarativeRegistry] Registered 42 Web Scripts (+0 failed), 44 URLs
08:04:12,277 INFO  [org.alfresco.web.scripts.AbstractRuntimeContainer] Initialised WebFramework Web Script Container (in 311.056ms)
08:04:12,380 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
08:04:20,190 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
08:07:26,578 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework

Does anyone have any ideas as to why things just stopped working? This has to be one of the most frustrating and finicky pieces of software I have ever used. I can start it up one day and everything is fine. The next time I start it I get all kinds of errors for no reason.

Thanks in advance for any help given.

Matt

Outcomes