AnsweredAssumed Answered

Executing application from the command line

Question asked by mike__ on Oct 12, 2011
Hello,

I have created an application with the Alfresco SDK under Eclipse. This application works fine when executed from Eclipse.
But the goal of this application is to be executed from the command line.

I created a jar of this application (without a main). Then executed a class with a main that run the method of my application.

I had some problems with the xml configuration files of alfresco. It seemed that this files couldn't be accessible. I solved this issues by copying lib\server\config\alfresco\* in my execution folder under alfresco\* . As my classpath integrate the execution folder the files were found.

This solution worked with alfresco 3.4 (I don't remember the letter version); but I upgraded alfresco to the 3.4.e version and now this solution doesn't work !!!

I don't understand why. Can you explain to me how can I generate my application from Eclipse to be able to execute it from the command line ?

Thank you very much because I really need help.

Outcomes