AnsweredAssumed Answered

Troubles with remote OpenOffice connection

Question asked by jaba on Jul 28, 2009
Latest reply on Jul 29, 2009 by jaba
Hi everyone,

I'm experienced some troubles with the remote openoffice connection.
I have configured an Alfresco server on one machine and Open Office to run on another machine on the 8100 tcp port.
My remote-openoffice-context.xml is below

I can see in the logs that the remote-openoffice is trying to open a connection :
18:03:00,017  DEBUG [openoffice.connection.SocketOpenOfficeConnection] connecting

But using Tcpdump i can see that no connection is occuring from my serveur to the Open Office machine:
root@alfresco:~ # tcpdump -X -s 1412 -nn -vvv host openoffice
tcpdump: listening on en2, link-type 1, capture size 1412 bytes
……nothing

I have no more idea where to look
Any help is welcome
Thanks




remote-openoffice-context.xml:
<?xml version='1.0' encoding='UTF-8' ?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>
<beans>
<bean id="openOfficeConnection" class="net.sf.jooreports.openoffice.connection.SocketOpenOfficeConnection">
        <constructor-arg type="java.lang.String" value="10.102.33.132"/>
        <constructor-arg type="int" value="8100"/>
</bean>
<bean id="transformer.OpenOffice" class="org.alfresco.repo.content.transform.RemoteOpenOfficeContentTransformer" parent="baseContentTrans
former" >
        <property name="connection">
                <ref bean="openOfficeConnection" />
        </property>
        <property name="documentFormatsConfiguration">
                <value>classpath:alfresco/mimetype/openoffice-document-formats.xml</value>
        </property>
</bean>
</beans>

Outcomes