AnsweredAssumed Answered

My hostname is not localhost!

Question asked by xkahn on Nov 16, 2009
I have a test Alfresco install running on RHEL 5, and mostly things work fine.  But the server seems to really believe that its URL is http://localhost/ (!)

For example, if I enable the imap server:
#
# IMAP
#————-
imap.server.enabled=true
imap.server.port=143
imap.server.host=my-test-machine.lab.myhost.org

The messages contain URLs like this:
Content folder:   http://localhost:8080/alfresco/navigate/browse/webdav/User%20Homes/xkahn/test

which obviously won't work since no clients (including myself) access the server from the server.

But also, if I load the page:
https://my-test-machine.lab.myhost.org/alfresco/service/index/all.mediawiki?family=CMIS&desc=CMIS%20Draft

all the links look like this:
[http://localhost:8080/alfresco/service/api/repository GET /alfresco/service/api/repository]

What do I need to set to fix this?
I tried setting:

web.application.context.url=http://my-test-machine.lab.myhost.org:8080/alfresco
repo.remote.endpoint.url=http://my-test-machine.lab.myhost.org:8080/alfresco/service

in tomcat/shared/classes/alfresco-global.properties

but no love.

Outcomes