AnsweredAssumed Answered

An initial OpenOffice connection could not be established

Question asked by geniak on Jul 30, 2009
Hello,

Having some problems all of a sudden getting OpenOffice.org working with Alfresco. It worked at one point, but not sure why it could be failing now. Below is my log


11:32:38,802 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from class path resource [alfresco/repository.properties]
11:32:38,804 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from class path resource [alfresco/domain/transaction.properties]
11:32:38,804 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from URL [file:/usr/local/alfresco/alfresco-global.properties]
11:32:38,805 INFO  [org.alfresco.config.JndiPropertiesFactoryBean] Loading properties file from URL [file:/usr/local/alfresco/tomcat/shared/classes/alfresco-global.properties]
11:32:39,023 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
11:33:07,040 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
11:33:08,602 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
11:33:12,180 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent] Index recovery started: 487 transactions.
11:33:14,614 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    10 % complete.
11:33:14,614 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    20 % complete.
11:33:14,616 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    30 % complete.
11:33:14,616 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    40 % complete.
11:33:14,616 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    50 % complete.
11:33:14,624 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    60 % complete.
11:33:14,644 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    70 % complete.
11:33:14,644 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    80 % complete.
11:33:14,665 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    90 % complete.
11:33:14,719 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent]    100 % complete.
11:33:17,265 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'thirdparty' subsystem, ID: [default]
11:33:17,440 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
11:33:19,554 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.
11:33:19,555 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'thirdparty' subsystem, ID: [default] complete
11:33:30,430 ERROR [org.alfresco.repo.node.index.AbstractReindexComponent.threads] Reindexer     1 failed with error: Node without parents does not have root aspect: workspace://SpacesStore/be23ae5a-5ec5-48e4-a200-35fe993a5e63.
11:33:34,207 INFO  [org.alfresco.repo.node.index.FullIndexRecoveryComponent] Index recovery completed.
11:33:34,937 WARN  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco 'dir.root' property is set to a relative path './alf_data'.  'dir.root' should be overridden to point to a specific folder.
11:33:34,937 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: ./alf_data
11:33:35,289 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
11:33:36,288 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] No patches were required.
11:33:36,293 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 0 module(s).
11:33:36,341 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'fileServers' subsystem, ID: [default]
11:33:36,477 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
11:33:37,656 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'Authentication' subsystem, ID: [managed, alfrescoNtlm1]
11:33:37,676 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
11:33:38,502 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'Authentication' subsystem, ID: [managed, alfrescoNtlm1] complete
11:33:43,572 ERROR [org.alfresco.fileserver] Failed to get local domain/workgroup name, using default of WORKGROUP
11:33:43,572 ERROR [org.alfresco.fileserver] (This may be due to firewall settings or incorrect <broadcast> setting)
11:33:43,652 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'fileServers' subsystem, ID: [default] complete
11:33:43,652 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'imap' subsystem, ID: [default]
11:33:43,721 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
11:33:43,787 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'imap' subsystem, ID: [default] complete
11:33:43,787 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'Synchronization' subsystem, ID: [default]
11:33:43,802 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
11:33:43,841 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'Synchronization' subsystem, ID: [default] complete
11:33:43,914 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.6.0_14-b08; maximum heap size 910.250MB
11:33:43,915 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Community): Current version 3.2.0 (2039) schema 2019 - Installed version 3.2.0 (2039) schema 2019
11:34:05,652 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'wcm_deployment_receiver' subsystem, ID: [default]
11:34:05,697 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
11:34:06,055 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'wcm_deployment_receiver' subsystem, ID: [default] complete
11:27:00,369 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework
11:34:16,423 INFO  [org.alfresco.web.site.FrameworkHelper] Successfully Initialized Web Framework

in "tomcat/shared/classes/alfresco-global.properties" I have "ooo.exe=soffice" uncommitted. At one point I even tried directly pointing to it via:

ooo.exe=/usr/lib64/ooo3/program/soffice

I would appreciate some help or some insight on what is going on. Thanks.

Myron L Stewart
Ingeniak, LLC

Outcomes