AnsweredAssumed Answered

Including Webscripts in Webforms

Question asked by vesuinfo on Aug 5, 2009
Latest reply on Aug 17, 2009 by scottf
Hi,

I am trying to include the Webscript in Webform XSD file,

but i am getting the following error:
16:16:58,625 User:admin WARN  [bean.wcm.CreateFormWizard] non fatal errors encountered parsing schema Wapcontent.xsd
error parsing schema:
at line 3 column 58: schema_reference.4: Failed to read schema document 'webscript://sample/header', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd

16:17:36,120 User:admin ERROR [forms.xforms.XFormsProcessor] org.alfresco.web.forms.xforms.FormBuilderException: errors parsing schema:
at line -1 column -1: A DOCTYPE is not allowed in content.
at line 25 column 10: A DOCTYPE is not allowed in content.

16:17:36,120 User:admin ERROR [ui.common.Utils] org.alfresco.web.forms.xforms.FormBuilderException: errors parsing schema:
at line -1 column -1: A DOCTYPE is not allowed in content.
at line 25 column 10: A DOCTYPE is not allowed in content.

org.alfresco.web.forms.FormProcessor$ProcessingException: org.alfresco.web.forms.xforms.FormBuilderException: errors parsing schema:
at line -1 column -1: A DOCTYPE is not allowed in content.
at line 25 column 10: A DOCTYPE is not allowed in content.

        at org.alfresco.web.forms.xforms.XFormsProcessor.process(XFormsProcessor.java:151)
        at org.alfresco.web.forms.xforms.XFormsProcessor.process(XFormsProcessor.java:127)
        at org.alfresco.web.ui.wcm.component.UIFormProcessor.encodeBegin(UIFormProcessor.java:123)
        at javax.faces.webapp.UIComponentTag.encodeBegin(UIComponentTag.java:467)
        at javax.faces.webapp.UIComponentTag.doStartTag(UIComponentTag.java:320)


I am trying to include the webscript in the weform,

xsd file:
<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
   xmlns:as="http://www.alfresco.org/alfresco/as"
           targetNamespace="http://www.alfresco.org/alfresco/as"
         elementFormDefault="qualified">      
   <xs:include schemaLocation="webscript://sample/header" /> 
  <xs:element name="simple">
    <xs:complexType>
      <xs:sequence>
        <xs:element name="string" type="xs:normalizedString"/>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
</xs:schema>

webscript file:
<webscript>
<shortname>Argument Handling Sample</shortname>
<description>Demonstrate access to single and multi-valued arguments</description>
<url>/sample/header</url>
<authentication>user</authentication>
</webscript>

and this web script is already reistered and avialable in the url,
please let me know if am doing some thing wrong?

Thanks,
Saravanan.

Outcomes