AnsweredAssumed Answered

Web Form workflow issue in Alfresco 4.0.b?

Question asked by wilsonb on Oct 28, 2011
Latest reply on Dec 5, 2013 by chintanp7
I have recently tried to use 4.0.b to see if we could move over to this sometime soon. However I had an issue with it when I tried to create an existing (working on 3.4.d) Web Form. When I get to the workflow step I get an error on the screen with some of the following text:

javax.faces.FacesException: An exception occurred processing JSP page /jsp/wizard/container.jsp at line 136

133: <td style="width: 100%;" valign="top">
134: <f:subview id="wizard-body">
135: <h:outputText id="validation_invalid_character" style="display:none" value="#{msg.validation_invalid_character}" />
136: <jsp:include page="<%=Application.getWizardManager().getPage() %>" />
137: </f:subview>
138: </td>
139: </tr>


Stacktrace:
caused by:
org.apache.jasper.JasperException: An exception occurred processing JSP page /jsp/wizard/container.jsp at line 136


******* a lot of extra stacktrace goes on here, you can have it if you want it *****

caused by:
org.alfresco.service.cmr.workflow.WorkflowException: 09280072 Workflow Component for engine id 'jbpm' is not registered
Now to what I have installed: I have Alfresco 4.0.b running on Ubuntu with MySQL (I admit 5.1 not 5.5 but that’s what we have to run on) and I have also installed the alfresco-community-avm-4.0.b.zip. This gave me the expected Web Forms but I either appear to be missing something fundamental or there is an issue somewhere. I also downloaded the Windows installed and ran it against the standard PostgreSQL install and got the same error. Am I missing something?

Outcomes