AnsweredAssumed Answered

IMAP not working - Ubuntu 9.04 & Alfresco 3.2

Question asked by oblivian on Aug 8, 2009
Latest reply on Feb 11, 2010 by dangruhn
System: Ubuntu Server 9.04 - Alfresco 3.2 Community (I installed from partner repository. "apt-get install alfresco-community". Most settings default).

Hello,

I am trying to get IMAP to work with Alfresco. I have enabled IMAP in /usr/share/tomcat6/shared/classes/alfresco-global.properties
I followed this guide: http://wiki.alfresco.com/wiki/IMAP
I also selected misc sites as Favourites from Share.

This is the output from alfresco.log
00:00:21,970 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Starting 'imap' subsystem, ID: [default]
00:00:21,977 INFO  [org.alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
00:00:22,054 INFO  [org.alfresco.repo.imap.AlfrescoImapServer] IMAP service started on host:port 10.70.10.20:143.
00:00:22,054 INFO  [org.alfresco.repo.management.subsystems.ChildApplicationContextFactory] Startup of 'imap' subsystem, ID: [default] complete

When trying to connect with Thunderbird and Microsoft Mail I get a Connection Refused message.
Is there anything else I have to do?

EDIT: I have also tried different IMAP hostnames: localhost, host.domain.tld, host.local.lan, 0.0.0.0 and xxx.xxx.xxx.xxx. No luck…
EDIT2: I have also tried to set the IMAP server to listen on an unpriviliged port and use IP-tables to NAT/Redirect. Still nuttin'…

Please advice,

Oblivian

Outcomes