AnsweredAssumed Answered

Patch error during Migration

Question asked by paul.lahitte on Aug 10, 2009
Hi all,
I am trying to upgrade from community 2.1 to 3dlabs running on linux suze 10.1 and mysql 5.0 , during upgrade after sql scripts I have an error during the Patches application:


=====================================
14:51:16,924 User:System INFO  [admin.patch.PatchExecuter]
=== Applied patch                 ===
ID: patch.updateAvmPermissions
RESULT:
Updated ACLs. Created 0 defining and 0 layered ACLs.
=====================================

=== Failed to apply patch         ===
ID: patch.updateDmPermissions
RESULT:
[b]org.alfresco.service.namespace.InvalidQNameException: A QName must consist of a local name
   at org.alfresco.service.namespace.QName.createQName(QName.java:70)[/b]
   at org.alfresco.repo.node.db.hibernate.HibernateNodeDaoServiceImpl.convertToChildAssocRefs(HibernateNodeDaoServiceImpl.java:2327)
   at org.alfresco.repo.node.db.hibernate.HibernateNodeDaoServiceImpl.getChildAssocs(HibernateNodeDaoServiceImpl.java:1964)
   at sun.reflect.GeneratedMethodAccessor486.invoke(Unknown Source)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:597)
   at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:296)
   at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:177)
   at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:144)
   at org.alfresco.repo.transaction.TransactionalDaoInterceptor.invoke(Transac…
=====================================
14:51:16,924 User:System INFO  [admin.patch.PatchExecuter]
=== Applied patch                 ===
ID: patch.wcmPermissionPatch
RESULT:
Updated ACLs: ACLS are moved to the staging area store and removed from all other stores. They are now applied via layering.
=====================================




All others pacthes seem to apply correctly .
Can some one give me a clue on what might be the source of this problem "QNAME"   ?

Thank's

Outcomes