AnsweredAssumed Answered

Alfresco 4, Solr problems

Question asked by leftcase on Nov 2, 2011
Latest reply on Nov 2, 2011 by leftcase
I'm having terrible problems with Alfresco 4 & Solr.

When I run a search, it seems that only files from the default demo site are returned. This would indicate to me that solr isn't indexing. However, when checking https://localhost:8443/solr/alfresco/admin/replication/index.jsp (from the server hosting Alfresco) I see that the size of the local index is increasing. I am seeing tons of errors as described here https://forums.alfresco.com/en/viewtopic.php?f=9&t=41569 (although the errors must be particularly unusual as noone has replied yet)

Also, as I've just noticed, looking at the solr index folder at D:\Alfresco\alf_data\solr\workspace\SpacesStore\index, none of the files have been modified since the server was last started 40 minutes ago (by checking each files last modified attribute). The replication page here: https://localhost:8443/solr/alfresco/admin/replication/index.jsp however suggests that Index version is incrementing and the size growing.

Finally, trying to add a tag to a calendar event by selecting 'choose from popular tags on this site' results in a message 'Failure: Cannot load tags from the server (connection down?)'

I wonder if anyone would be kind enough to run their eyes across my configuration and tell me whether or not the see anything wrong with it please? I'm really struggling with this. :oops:

This my configuration

Tomcat: 8009:AJP1.3:listening to 127.0.0.1  <–>   Apache 2.2 mod j/k: 443:https   <–>  End users
        8443:listening to 127.0.0.1
        8080:listening to 127.0.0.1
       

server.xml

<?xml version='1.0' encoding='utf-8'?>
<Server port="8005" shutdown="SHUTDOWN">

  <!–APR library loader. Documentation at /docs/apr.html –>
  <Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on" />
  <!–Initialize Jasper prior to webapps are loaded. Documentation at /docs/jasper-howto.html –>
  <Listener className="org.apache.catalina.core.JasperListener" />
  <!– Prevent memory leaks due to use of particular java/javax APIs–>
  <Listener className="org.apache.catalina.core.JreMemoryLeakPreventionListener" />
  <!– JMX Support for the Tomcat server. Documentation at /docs/non-existent.html –>
  <Listener className="org.apache.catalina.mbeans.ServerLifecycleListener" />
  <Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener" />

  <!– Global JNDI resources
       Documentation at /docs/jndi-resources-howto.html
  –>
  <GlobalNamingResources>
    <!– Editable user database that can also be used by
         UserDatabaseRealm to authenticate users
    –>
    <Resource name="UserDatabase" auth="Container"
              type="org.apache.catalina.UserDatabase"
              description="User database that can be updated and saved"
              factory="org.apache.catalina.users.MemoryUserDatabaseFactory"
              pathname="conf/tomcat-users.xml" />
  </GlobalNamingResources><Service name="Catalina">

    <Connector port="8080" URIEncoding="UTF-8" protocol="HTTP/1.1"
               connectionTimeout="20000"
          redirectPort="8443"
          address="127.0.0.1"/>
<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" address="127.0.0.1" />
<Connector port="8443" protocol="org.apache.coyote.http11.Http11Protocol" SSLEnabled="true" address="127.0.0.1"
               maxThreads="150" scheme="https" keystoreFile="D:\Alfresco/alf_data/keystore/ssl.keystore" keystorePass="*********" keystoreType="JCEKS"
secure="true" connectionTimeout="240000" truststoreFile="D:\Alfresco/alf_data/keystore/ssl.truststore" truststorePass="*********" truststoreType="JCEKS"
          clientAuth="false" sslProtocol="TLS" allowUnsafeLegacyRenegotiation="true" />
<Engine name="Catalina" defaultHost="localhost">
      <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
             resourceName="UserDatabase"/>
      <Host name="localhost"  appBase="webapps"
            unpackWARs="true" autoDeploy="true"
            xmlValidation="false" xmlNamespaceAware="false">

solrcore.properties

data.dir.root=D:\Alfresco/alf_data/solr
data.dir.store=workspace/SpacesStore
enable.alfresco.tracking=true
cache.alfresco.size=100
max.field.length=2147483647

alfresco.host=localhost
alfresco.port=8080
alfresco.port.ssl=8443

alfresco.cron=0/15 * * * * ? *
alfresco.stores=workspace://SpacesStore
alfresco.lag=1000
alfresco.hole.retention=3600000
alfresco.batch.count=1000

# encryption

# none, https
alfresco.secureComms=https

# ssl
alfresco.encryption.ssl.keystore.type=JCEKS
alfresco.encryption.ssl.keystore.provider=
alfresco.encryption.ssl.keystore.location=ssl.repo.client.keystore
alfresco.encryption.ssl.keystore.passwordFileLocation=ssl-keystore-passwords.properties
alfresco.encryption.ssl.truststore.type=JCEKS
alfresco.encryption.ssl.truststore.provider=
alfresco.encryption.ssl.truststore.location=ssl.repo.client.truststore
alfresco.encryption.ssl.truststore.passwordFileLocation=ssl-truststore-passwords.properties

relevant alfresco.global.properties config


alfresco.context=alfresco
alfresco.host=alfrescoserver
alfresco.port=443
alfresco.protocol=https

share.context=share
share.host=alfrescoserver
share.port=443
share.protocol=https

### Solr indexing ###
index.subsystem.name=solr
solr.host=localhost
dir.keystore=${dir.root}/keystore
solr.port=8443


index.html of root webapp (changed to get rid of default Tomcat page)


<html>
   <head>
      <meta http-equiv="refresh" content="0;URL=share/">
   </head>
</html>

Outcomes