AnsweredAssumed Answered

can't start the WCM Deployment Engine

Question asked by yahoon on Aug 11, 2009
Latest reply on Oct 7, 2009 by ludrik
I am debuging my WCM Deployment .
My alfresco 3.2 is running on linux ,ip 10.1.1.5

I am installing WCM Deployment Engine on linux, ip 10.1.1.6.
I downloaded the zip file alfresco-community-deployment-3.2.zip
extract it to the dir /opt/deployment

then edit the start script 'deploy_start.sh'
#!/bin/sh
nohup java -server -Djava.rmi.server.hostname=10.1.1.6 -Djava.ext.dirs=. org.alfresco.deployment.Main application-context.xml
just addd -Djava.rmi.server.hostname=10.1.1.6 in the java command

then I run
./deploy_start.sh under the installation dir.
fails, here is the log in nohup.out
log4j:WARN No appenders could be found for logger (org.alfresco.deployment.Main).
log4j:WARN Please initialize the log4j system properly.
Unable to start deployment receiver
org.springframework.beans.factory.BeanInitializationException: Could not load properties; nested exception is java.io.FileNot
FoundException: class path resource [deployment.properties] cannot be opened because it does not exist
Caused by: java.io.FileNotFoundException: class path resource [deployment.properties] cannot be opened because it does not ex
ist
        at org.springframework.core.io.ClassPathResource.getInputStream(ClassPathResource.java:135)
        at org.springframework.core.io.support.PropertiesLoaderSupport.loadProperties(PropertiesLoaderSupport.java:179)
        at org.springframework.core.io.support.PropertiesLoaderSupport.mergeProperties(PropertiesLoaderSupport.java:158)
        at org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigu
rer.java:68)
        at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplication
Context.java:472)
        at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:334)
        at org.springframework.context.support.FileSystemXmlApplicationContext.<init>(FileSystemXmlApplicationContext.java:12
4)
        at org.springframework.context.support.FileSystemXmlApplicationContext.<init>(FileSystemXmlApplicationContext.java:68
)
        at org.alfresco.deployment.Main.main(Main.java:54)

strangely ,if I moved the installation zip file  into this dir , it goes well.
I don't why, is it necessary to keep the installation zip file under the installation dir ?
any ideas ? thanks

Outcomes