AnsweredAssumed Answered

vti/sharepoint https issue

Question asked by nadaoneal on Aug 13, 2009
Latest reply on Nov 10, 2009 by petebeaz
Hi, I'm having a weird problem with the "Edit online" option. My site is https. The link for "edit online" goes to https://mysite:7070/path/to/doc , which returns "Internet Explorer cannot display the webpage." Strangely, though, if I change the URL manually to http, everything works file. The behavior is the same with both of the following settings blocks in alfresco-global.properties (using Alfresco Community 3.2 on RHEL):

vti.server.port=7070
vti.alfresco.deployment.context=/alfresco
vti.alfresco.alfresoHostWithPort=https://mysite:8443
vti.share.shareHostWithPort=https://mysite:8443

and

vti.server.port=7070
vti.alfresco.deployment.context=/alfresco
vti.alfresco.alfresoHostWithPort=http://mysite:8080
vti.share.shareHostWithPort=http://mysite:8080

… I'd rather that vti was working over https, if I had a choice, since authentication information is being sent. Can SharePoint use https over 7070? Do I just need to use a different port number? I've seen this solution, but it doesn't quite address the problem of the https://:7070 mismatch - there, it looks like the connection is defaulting to http://. (unless I'm misunderstanding)

Also: does anyone know the best way to hide the "Edit Online" option until I have this fixed?

Thanks everyone!

Outcomes