AnsweredAssumed Answered

Auto-deploy not working with File System Deployment Target

Question asked by pyppe on Dec 4, 2009
Latest reply on Dec 4, 2009 by pyppe
Hi.

We cannot get the auto-deployment to work with our File System Deployment Target. We are using the following filesystem-deployment target:


  <bean
    class="org.alfresco.deployment.impl.server.DeploymentTargetRegistrationBean"
    init-method="register">

    <property name="name">
      <value>vnkpFilesystem</value>
    </property>
    <property name="registry">
      <ref bean="deploymentReceiverEngine" />
    </property>

    <property name="target">
      <bean
        class="org.alfresco.deployment.impl.fsr.FileSystemDeploymentTarget"
        init-method="init">
        <property name="rootDirectory">
          <value>${deployment.filesystem.default.rootdir}</value>
        </property>

        <!–  where to store meta data –>
        <property name="metaDataDirectory">
          <value>${deployment.filesystem.default.metadatadir}</value>
        </property>

        <property name="autoFix">
          <value>${deployment.filesystem.autofix}</value>
        </property>
        <property name="fileSystemReceiverService">
          <ref bean="fileSystemReceiverService" />
        </property>

        <!–  how to authenticate for this particular target –>
        <property name="authenticator">
          <bean
            class="org.alfresco.repo.deploy.DeploymentReceiverAuthenticatorAuthenticationService"
            init-method="init">
            <property name="authenticationService">
              <ref bean="AuthenticationService" />
            </property>
          </bean>
        </property>

        <!– Target Event Handlers –>
        <property name="postCommit">
          <list>
            <bean class="fi.vn.kp.alfresco.deployment.PostDeploymentRunnable">
              <property name="command">
                <value>${vnkp.post-deployment.command}</value>
              </property>
              <property name="directory">
                <value>${vnkp.post-deployment.directory}</value>
              </property>
            </bean>
          </list>
        </property>
      </bean>
    </property>
  </bean>

The web-project has been configured to use the above-mentioned Live Server for deployments. And manually deploying works OK.

However, when you select some file and submit it to staging sandbox through a workflow (and select the auto-deploy), nothing happens. Why is that? How do you enable the auto-deployment?

- Pyppe

Outcomes