AnsweredAssumed Answered

Edit Online and SPP connection always open read-only

Question asked by cybertoast on Dec 16, 2009
Something changed in my 3.2 install that causes all Edit Online operations in IE to open MSOffice files as read-only. I've tried connecting directly via SPP (, and receive the same problem. I've applied the OpenDocumentsReadWriteWhileBrowsing registry change, and I've checked with both Office 2003 and 2007. Same results in all cases. Edit Offline and re-upload works, as does webdav.

This is a file that I uploaded into a folder that I created in a Site that I created. I'm wondering if there are permission issues that I need to be aware of, or some client-tools that need to be installed to make everything work. As I recall when I first downloaded Alfresco 3.2 this worked.

I've since added SSL to Apache (so Apache SSL -> AJP -> Alfresco port 8443), but that does not affect the SPP side (I had to hard-code documentlist.js to use http instead of https since SPP and port 7070 don't seem to like SSL - perhaps there's a configuration to make this happen?). But my understanding is that SSL should not be a problem since directly opening a document from MSWord via the SPP URL also opens read-only.

What are the things I should check or be aware of to ensure that SPP and Edit Online work for all MSOffice users? What permissions must a user have to be able to Edit Online or edit via SPP?

Thanks much.