AnsweredAssumed Answered

Elusive Sharepoint

Question asked by sreilly on Sep 2, 2009
Latest reply on Sep 22, 2009 by elmuchacho
Hi all,
I've installed alfresco-community 3.2-9 from the Ubuntu 9.04 repositories and both the Explore and Share areas work.
However, I can't get the Sharepoint Protocol to work.
When I try to create a new Document Workspace in Word 2007 I get the message "The action could not be completed."
I read through the ECM_InstallConfigure_CommunityEdition32.pdf and it looked like I had not installed the vti-module.amp so I did that using the downloaded alfresco-mmt.jar thus;

/etc/init.d/tomcat6 stop
java -jar alfresco-mmt-3.2.jar install vti-module.amp /usr/share/tomcat6/webapps/alfresco.war -verbose

That went well and it appeared to install OK;

java -jar alfresco-mmt-3.2.jar list /usr/share/tomcat6/webapps/alfresco.war
Module 'org.alfresco.module.vti' installed in '/usr/share/tomcat6/webapps/alfresco.war'
   -    Title:        Vti
   -    Version:      1.2
   -    Install Date: Wed Sep 02 17:04:36 BST 2009
   -    Desription:   Alfresco Vti Extension

I also modified the alfresco-global.properties file as instructed;

vti.server.port=7070
vti.alfresco.deployment.context=/alfresco
vti.alfresco.alfresoHostWithPort=http://myserver:8080
vti.share.shareHostWithPort=http://myserver:8080

Restart tomcat6 and still no joy. Same message in Word.

The thing is that when I did a preview of the install of vti-module.amp it said it would create files in /var/lib/tomcat6/webapps/alfresco/WEB-INF/classes/alfresco/module/org.alfresco.module.vti but that directory (org.alfresco.module.vti) doesn't appear when tomcat starts.

So, what am I doing wrong?

TIA,

Steve

Outcomes