AnsweredAssumed Answered

Can't deploy amps

Question asked by clauded1 on Sep 2, 2009
Latest reply on Oct 22, 2009 by gronfelt
Seems like I can't deploy amps on linux with 3.2.

Steps to reproduce :

copy amps to /opt/Alfresco/amps
run apply_amps.sh


alf01:/opt/Alfresco/amps # ll
total 6504
-rwxr-xr-x 1 root root     391 juil. 14 05:19 add-amps-here.txt
-rw-r–r– 1 root root 4269766 sept.  2 15:14 org.alfresco.module.mediawikiintegration-unsupported.amp
-rw-r–r– 1 root root 1467086 sept.  2 15:14 phpIntegration-unsupported.amp
-rwxr-xr-x 1 root root  890595 août 28 14:14 vti-module.amp

alf01:/opt/Alfresco/amps # ../apply_amps.sh
This script will apply all the AMPs in ./amps to the alfresco.war file in /opt/Alfresco/tomcat\webapps
Press control-c to stop this script . . .
Press any other key to continue . . .

Module managment tool available commands:
———————————————————–

install: Installs a AMP file(s) into an Alfresco WAR file, updates if an older version is already installed.
usage:   install <AMPFileLocation> <WARFileLocation> [options]
valid options:
   -verbose   : enable verbose output
   -directory : indicates that the amp file location specified is a directory.
                All amp files found in the directory and its sub directories are installed.
   -force     : forces installation of AMP regardless of currently installed module version
   -preview   : previews installation of AMP without modifying WAR file
   -nobackup  : indicates that no backup should be made of the WAR

———————————————————–

list:  Lists all the modules currently installed in an Alfresco WAR file.
usage: list <WARFileLocation>

———————————————————–

No modules are installed in this WAR file
No modules are installed in this WAR file
About to clean out tomcat/webapps/alfresco directory and temporary files…
Press control-c to stop this script . . .
Press any other key to continue . . .

sh: /opt/Alfresco/tomcat/bin/clean_tomcat.sh: Aucun fichier ou dossier de ce type

Seems like there an error in the script :


java -jar bin/alfresco-mmt.jar install ./amps $APPSERVER/webapps/alfresco.war -directory
java -jar bin/alfresco-mmt.jar list $APPSERVER/webapps/alfresco.war

The $APPSERVER variable is not initialized in the script (should be CATALINA_HOME?).

Original script :

#!/bin/sh
# ——-
# Script for apply AMPs to installed WAR
# ——-
ALF_HOME=/opt/Alfresco
export JAVA_HOME="/usr"
export PATH=$PATH:$JAVA_HOME/bin
cd "$ALF_HOME"
export CATALINA_HOME="$ALF_HOME"/tomcat
echo "This script will apply all the AMPs in ./amps to the alfresco.war file in $CATALINA_HOME\webapps"
echo "Press control-c to stop this script . . ."
echo "Press any other key to continue . . ."
read RESP
java -jar bin/alfresco-mmt.jar install ./amps $APPSERVER/webapps/alfresco.war -directory
java -jar bin/alfresco-mmt.jar list $APPSERVER/webapps/alfresco.war
echo "About to clean out tomcat/webapps/alfresco directory and temporary files…"
echo "Press control-c to stop this script . . ."
echo "Press any other key to continue . . ."
read DUMMY
rm -rf $CATALINA_HOME/webapps/alfresco
sh $CATALINA_HOME/bin/clean_tomcat.sh

Outcomes