AnsweredAssumed Answered

Problems with the installation of an AMP module in Linux

Question asked by agey on Dec 28, 2009
Latest reply on Jan 5, 2010 by agey
Hi all,

I have created an AMP module to extend Alfresco and configure it. The AMP module bootstrap a custom model into the repository using the following Spring configuration added to module-context.xml:


<bean id="extension.dictionaryBootstrap" parent="dictionaryModelBootstrap" depends-on="dictionaryBootstrap">
        <property name="models">
            <list>
                <value>alfresco/module/org.alfresco.custom/model/customModel.xml</value>
            </list>
        </property>
    </bean>   

This works fine in version 3.0 of Alfresco for Windows but the Linux version doesn´t load the customModel. Can anyone point me how to make the AMP module to work well in the Linux version? Should I add the following configuration to the module-context.xml?

<import resource="classpath:alfresco/module/org.alfresco.custom/custom-model-context.xml" />
custom-model-context.xml:

<bean id="myModule_dictionaryBootstrap" parent="dictionaryModelBootstrap" depends-on="dictionaryBootstrap">
     <property name="models">
        <list>
            <value>alfresco/module/org.alfresco.custom/model/customModel.xml</value>
        </list>
     </property>
  </bean>

Thanks in advance.

Outcomes