AnsweredAssumed Answered

content replication  question

Question asked by clarencemei on Jan 14, 2010
Latest reply on Jan 15, 2010 by clarencemei
I want to install alfresco and replication all data on two sites.Alfter testing ,i prepare use DFS driver to replication all content between chinese and american.
I have configure replication on two virtual server,but i have some question:
my configure
1.Two server use one shard driver to make a contentstorage  "z:/alf_data"
2.replicating-content-services-context.xml
<bean id="localDriveContentStore" class="org.alfresco.repo.content.filestore.FileContentStore">
      <constructor-arg>
         <value>z:/alf_data/contentstore</value>
      </constructor-arg>
   </bean>
   <bean id="networkContentStore" class="org.alfresco.repo.content.filestore.FileContentStore">
      <constructor-arg>
         <value>z:/alf_data/contentstore</value>
      </constructor-arg>
3.ehcache-custom.xml
   <cacheManagerPeerListenerFactory
            class="net.sf.ehcache.distribution.RMICacheManagerPeerListenerFactory"
          properties="port=40001,
      socketTimeoutMillis=30000"
4.alfresco-global.properties
index.recovery.mode=AUTO
index.tracking.cronExpression=0/5 * * * * ?
index.tracking.reindexLagMs=10000

In Alfresco explorer,When i finished add content,system will pop a error:
Failed to create content due to error: 00140030 Content replication failed. The content URL already exists in the target (secondary) store: Content: ContentAccessor[ contentUrl=store://2010/1/14/10/24/29d835f4-c6a4-422d-8f3a-9fddc2225d06.bin, mimetype=application/vnd.excel, size=17920, encoding=UTF-8, locale=en_US] Store: FileContentStore[ root=z:/alf_data/contentstore, allowRandomAccess=true, readOnly=false] Number: 0

In Alfresco share the same error on it:
00140031 Wrapped Exception (with status template): 00140030 Failed to execute script '/org/alfresco/repository/site/sites.post.json.js (in classpath store file:E:/Alfresco/tomcat/webapps/alfresco/WEB-INF/classes/alfresco/templates/webscripts)': 00140029 Content replication failed. The content URL already exists in the target (secondary) store:
    Content: ContentAccessor[ contentUrl=store://2010/1/14/10/43/0fe830a6-d6e6-4ede-a272-8ed3b4d8f8b3.bin, mimetype=text/plain, size=0, encoding=UTF-8, locale=zh_CN]
    Store: FileContentStore[ root=z:/alf_data/contentstore, allowRandomAccess=true, readOnly=false]
    Number: 0

Guys ,Please help me ,thanks

Clarence

Outcomes