AnsweredAssumed Answered

CIFS + Kerberos working at Enterprise 3.2, but not at Comm

Question asked by claudio.martins on Jan 17, 2010
Latest reply on Jan 19, 2010 by claudio.martins
Hello there,

I've been during all last week trying to get Alfresco Community 3.2 to work with Kerberos based authentication for our company across all OS clients available, and as many other people here at the forums and at Alfresco's Jira, I wasn't successful from Windows 2003 Server and all other versions that came after that, like Vista and Windows 7.

Last Friday, I found a Jira ticket for the Enterprise 3.1 release, and it looks like the issue that we're having has been corrected and moved forward to the Enterprise 3.2 released last week. The Jira ticket is this one: https://issues.alfresco.com/jira/browse/ETHREEOH-3225

I have checked out the 3.3 version from HEAD, and the same problem happens. When I found that ticket dating back from last November, I thought that this code would be already committed. I'm not entirely sure about Alfresco's release procedures of code applied at Enterprise editions and propagation to public SVN, but I think it was about time that this correction would be made available.

Here are the setups:

AD Server: Windows 2008 + AD - RC4_HMAC


Alfresco Server 1
Community Edition 3.2 - Debian 5 - JDK 6_17 x64
Auth Subsystem: Kerberos 5
Client Windows XP: Works
Client Windows Vista/SP1/Windows 7: Doesn't work

Alfresco Server 2
Community Edition 3.2r2 - Debian 5 - JDK 6_17 x64
Auth Subsystem: Kerberos 5
Client Windows XP: Works
Client Windows Vista/SP1/Windows 7: Doesn't work

Alfresco Server 3
Community Edition 3.3 from HEAD - Debian 5 - JDK 6_17 x64
Auth Subsystem: Kerberos 5
Client Windows XP: Works
Client Windows Vista/SP1/Windows 7: Doesn't work

Alfresco Server 4
Enterprise Edition 3.2 - Debian 5 - JDK 6_17 x64
Auth Subsystem: Kerberos 5
Client Windows XP: Works
Client Windows Vista/SP1/Windows 7: Works!!!!




Any ideas on when such code would be made available to Community Edition users?

Outcomes