AnsweredAssumed Answered

migrate from 2.1 to 3.0 create table problem

Question asked by emzvargas on Jan 26, 2010
hello im trying to perform an upgrade from alfresco 2.1 to 3.0

i basically follow the steps provided in this forum which are:
1.-perform a backup from alfresco mysql and alf_data
2.-install alfresco 3.0
3.-test to check that the installation went well
4.- restore alfresco db in mysql and replace alf_data

everything seems to be ok up to the point when it tries perform the auto schema update when it comes with the following error message:

20:07:33,916 ERROR [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema auto-update failed
java.sql.SQLException: Can't create table 'alfresco.alf_acl_member' (errno: 150)

Caused by: java.sql.SQLException: Can't create table 'alfresco.alf_acl_member' (errno: 150)
   at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1055)
   at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956)
   at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3491)

The alfresco user ive created has all privileges on the databases
ive tried to create this table manually but without success.
ive tried to turn off the auto schema  update but again comes up with different error messages.
Could some please help with this..or tried to point me out what im doing wrong  :?
Any help on this matter will be greatly appreciated  :D

Outcomes