AnsweredAssumed Answered

set alfresco development enviroment in eclipse

Question asked by timin on Jan 22, 2012
Latest reply on Mar 27, 2013 by aitbenmouh
Hi all.

I'm new to alfresco project.

Yesturday  i tried to set up alfresco in eclipse following the steps in the alfresco wiki

http://wiki.alfresco.com/wiki/Alfresco_on_Eclipse

it seems that the guide is incorrect or i do something wrong…

I've installed eclipse version 3.7.1,
tomcat 6
mysql
and all other software as recommended.

i've set up the eclipse enviroment accordinally…

i've downloaded the latest version from svn.

But once i tried to ctreate a new project and import there sources from previously created fresco_svn folder a number of errors appeared in it. Here trhey are:


Archive for required library: 'lib/spring/org.springframework.spring-library-3.0.5.RELEASE.libd' in project 'SystemBuildTest' cannot be read or is not a valid ZIP file   SystemBuildTest Build path   Build Path Problem

Invalid character constant   ADMLuceneTest.java   /Repository/source/java/org/alfresco/repo/search/impl/lucene   line 554   Java Problem

Project 'Extension Samples' is missing required source folder: 'source/java'   Extension Samples      Build path   Build Path Problem

Project 'SystemBuildTest' is missing required library: '/Web-Client/build/dist'   SystemBuildTest      Build path   Build Path Problem

The project cannot be built until build path errors are resolved   Extension Samples      Unknown   Java Problem

The project cannot be built until build path errors are resolved   SystemBuildTest      Unknown   Java Problem

The project was not built due to "Could not delete '/SDK Basic AMP/build/classes/org'.". Fix the problem, then try refreshing this project and building it since it may be inconsistent   SDK Basic AMP      Unknown   Java Problem
What should be done to fix that all?
Should i exclude the problematic projects?


the error in the Repository seems clear when you open the java file

 mlText.addValue(Locale.CHINESE, new String(new char[] { (char) ('香' + orderTextCount) }) + " 香蕉");


The '香'  is certainly a wrong character, so do we need to change somehow the encoding to utf-8 and if so than how?


Thanks in advance.

Outcomes