AnsweredAssumed Answered

OpenOffice connection works only when started manually

Question asked by mike54 on Sep 24, 2009
Latest reply on Oct 5, 2009 by mike54
Hi!

My configuration:
Centos 5.3 + Tomcat
ALfresco 3.2
OpenOffice 2.3

When I run this command from terminal:
/usr/lib/openoffice.org/program/soffice "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager""-env:Userinstallation=file://var/lib/alfresco/alf_data/oouser" -nologo -headless -nofirststartwizard
I can see OpenOffice running on process list. When I start Tomcat / Alfresco it works well and I can see document preview for ODT files.

I have placed those lines in a config file:
ooo.exe=/usr/lib/openoffice.org/program/soffice
ooo.user=${dir.root}/oouser

But it does not start automatically and I get the well known warning:
15:20:39,702 WARN  [org.alfresco.util.OpenOfficeConnectionTester] An initial OpenOffice connection could not be established.

I have placed openoffice-startup-context.xml file in:
/var/lib/tomcat5/shared/classes/alfresco/extension/bootstrap

When it is wrongly configured (eg points to wrong location) it will report error in Alfresco log.
When i t is configured correctly - no errors in log, but OO connection is not available (nothing on process list as well.)

My  openoffice-startup-context.xml contents is as follows:
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>
<beans>
   <bean id="openOfficeStartupBootstrap" class="org.alfresco.util.exec.RuntimeExecBootstrapBean" >
      <property name="startupCommands">
         <list>
            <ref bean="openOfficeStartupCommand" />
         </list>
      </property>

      <property name="failOnError">
         <value>false</value>
      </property>

   </bean>
   <bean id="openOfficeStartupCommand" class="org.alfresco.util.exec.RuntimeExec">
      <property name="commandMap">
          <map>
              <entry key=".*">
                  <value><![CDATA[/usr/lib/openoffice.org/program/soffice "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager""-env:Userinstallation=file://var/lib/alfresco/alf_data/oouser" -nologo -headless -nofirststartwizard]]></value>

              </entry>
          </map>
      </property>

      <property name="waitForCompletion">
         <value>false</value>
      </property>
      <property name="errorCodes">
         <value>2</value>
      </property>
   </bean>
</beans>

I have tried disabling SELinux and Firewall and any other thing that I could think of…
Please help!!!  :cry:

Outcomes