AnsweredAssumed Answered

problem starting CIFS with Enterprise 3.2.0

Question asked by abcbien on Jan 28, 2010
Latest reply on Feb 5, 2010 by vinhqchu
Hi,

trying to start CIFS on Enterprise 3.2.0, I set

in the file-servers.properties:
cifs.enabled=true
#cifs.serverName=${localname}A
cifs.serverName=ALF
cifs.domain=
cifs.broadcast=255.255.255.255
# An empty value indicates bind to all available network adapters
cifs.bindto=
cifs.ipv6.enabled=false
cifs.hostannounce=true
# Enable the use of asynchronous sockets/NIO code
cifs.disableNIO=false
# Disable the use of JNI code. Only currently affects Windows
cifs.disableNativeCode=false
# Session timeout, in seconds. Defaults to 15 minutes, to match the default Windows client setting.
# If no I/O is received within that time the session is closed by the server
cifs.sessionTimeout=900

# Can be mapped to non-privileged ports, then use firewall rules to forward requests from the standard ports
cifs.tcpipSMB.port=445
cifs.netBIOSSMB.sessionPort=139
cifs.netBIOSSMB.namePort=137
cifs.netBIOSSMB.datagramPort=138

# Optional WINS server primary and secondary IP addresses. Ignored if autoDetectEnabled=true
cifs.WINS.autoDetectEnabled=true
cifs.WINS.primary=1.2.3.4
cifs.WINS.secondary=5.6.7.8


In log4j.properties, I set:

# CIFS server debugging
log4j.logger.org.alfresco.smb.protocol=debug
log4j.logger.org.alfresco.smb.protocol.auth=debug


I don't see any log about CIFS and nbtstat -n doesn't show an alfresco entry.

How can I debug this ?

Second question: not clear for me: do we have to alter the alfresco-global.properties file to enable CIFS ? Or setting the parameters in the file-servers.xml is sufficient ? (I tried both with the same result but a clarification would be appreciated).

Thanks,
Alain

Outcomes